aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-06-20 03:54:13 +0800
committerbsam <bsam@FreeBSD.org>2013-06-20 03:54:13 +0800
commit650c844cb37c1c27a8590c224bd424797ed03aa5 (patch)
tree9ae1b5f0863fd1abd1ab55a16da29b2ffc6c6b74 /biology
parentb77b88131ad2592fbc870d45bd234c4bed1fa607 (diff)
downloadfreebsd-ports-gnome-650c844cb37c1c27a8590c224bd424797ed03aa5.tar.gz
freebsd-ports-gnome-650c844cb37c1c27a8590c224bd424797ed03aa5.tar.zst
freebsd-ports-gnome-650c844cb37c1c27a8590c224bd424797ed03aa5.zip
. NOPORTDOCS -> PORT_OPTIONS:MDOCS;
. mute mdir commands and unmute install commands; . do not use mkdir for parent directories (mkdir implies "-p"); . introduce EXAMPLE option (do not install examples to DOCSDIR); . bump PORTREVISION; . make use of PLIST_FILES, PORTDOCS and PORTEXAMPLES at Makefile; . get rid of pkg-plist; . use standard DOCSDIR and EXAMPLESDIR (instead of a PREFIX/foo/bar path); . trim Makefile headers.
Diffstat (limited to 'biology')
-rw-r--r--biology/psi88/Makefile29
-rw-r--r--biology/psi88/pkg-plist30
2 files changed, 17 insertions, 42 deletions
diff --git a/biology/psi88/Makefile b/biology/psi88/Makefile
index 462d17a122d9..fa1f901c4897 100644
--- a/biology/psi88/Makefile
+++ b/biology/psi88/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: Psi88
-# Date created: 1998-11-11
-# Whom: Ryo MIYAMOTO
-#
+# Created by: Ryo MIYAMOTO
# $FreeBSD$
-#
PORTNAME= psi88
PORTVERSION= 1.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= biology
MASTER_SITES= http://www.ccl.net/cca/software/SOURCES/FORTRAN/psi88/
DISTNAME= ${PORTNAME}
@@ -16,6 +12,13 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Plotting wavefunctions (molecular orbitals) in 3D
+PLIST_FILES+= bin/PSI1 bin/PSICON bin/PSI2CT bin/PSI2HP bin/PSI2PS bin/PSI2 \
+ bin/PREPLOT bin/preplot bin/rpsi1 bin/rpsi2 bin/rpsicon
+PORTDOCS= README psi88.doc
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.pre.mk>
USE_FORTRAN= yes
@@ -35,12 +38,14 @@ post-install:
${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/unix/rpsi1 ${PREFIX}/bin/
${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/unix/rpsi2 ${PREFIX}/bin/
${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/unix/rpsicon ${PREFIX}/bin/
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/psi88
- ${MKDIR} ${PREFIX}/share/doc/psi88/examples
- @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README ${PREFIX}/share/doc/psi88
- @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/psi88.doc ${PREFIX}/share/doc/psi88
- @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/examples/* ${PREFIX}/share/doc/psi88/examples
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/psi88.doc ${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/examples/* ${EXAMPLESDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/biology/psi88/pkg-plist b/biology/psi88/pkg-plist
deleted file mode 100644
index dc8966983621..000000000000
--- a/biology/psi88/pkg-plist
+++ /dev/null
@@ -1,30 +0,0 @@
-bin/PSI1
-bin/PSICON
-bin/PSI2CT
-bin/PSI2HP
-bin/PSI2PS
-bin/PSI2
-bin/PREPLOT
-bin/preplot
-bin/rpsi1
-bin/rpsi2
-bin/rpsicon
-%%PORTDOCS%%%%DOCSDIR%%/psi88.doc
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/examples/ad634a.psi1
-%%PORTDOCS%%%%DOCSDIR%%/examples/ad634a.psi2
-%%PORTDOCS%%%%DOCSDIR%%/examples/ad634a.psicon
-%%PORTDOCS%%%%DOCSDIR%%/examples/ad635a.psi1
-%%PORTDOCS%%%%DOCSDIR%%/examples/ad635a.psi2
-%%PORTDOCS%%%%DOCSDIR%%/examples/ad635a.psicon
-%%PORTDOCS%%%%DOCSDIR%%/examples/ad636a.psi1
-%%PORTDOCS%%%%DOCSDIR%%/examples/ad636a.psi2
-%%PORTDOCS%%%%DOCSDIR%%/examples/ad636a.psicon
-%%PORTDOCS%%%%DOCSDIR%%/examples/ch3cl.psi1
-%%PORTDOCS%%%%DOCSDIR%%/examples/ch3cl.psi2
-%%PORTDOCS%%%%DOCSDIR%%/examples/ch3cl.psicon
-%%PORTDOCS%%%%DOCSDIR%%/examples/test.psi1
-%%PORTDOCS%%%%DOCSDIR%%/examples/test.psi2
-%%PORTDOCS%%%%DOCSDIR%%/examples/test.psicon
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples
-%%PORTDOCS%%@dirrm %%DOCSDIR%%