aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2016-05-10 00:37:44 +0800
committerolivierd <olivierd@FreeBSD.org>2016-05-10 00:37:44 +0800
commitdf0f0443ef912d00eaaac8959980160b48bef738 (patch)
tree84a1a89316adf9732c48a7052d3ef61848b1459e /biology
parent4c2ac6ff9f2919b1b694ec4e6ead4693d926e9fc (diff)
downloadfreebsd-ports-gnome-df0f0443ef912d00eaaac8959980160b48bef738.tar.gz
freebsd-ports-gnome-df0f0443ef912d00eaaac8959980160b48bef738.tar.zst
freebsd-ports-gnome-df0f0443ef912d00eaaac8959980160b48bef738.zip
The BIOM file format (canonically pronounced biome) is designed to be a
general-use format for representing biological sample by observation contingency tables. BIOM is a recognized standard for the Earth Microbiome Project and is a Genomics Standards Consortium supported project. The BIOM format is designed for general use in broad areas of comparative -omics. For example, in marker-gene surveys, the primary use of this format is to represent OTU tables: the observations in this case are OTUs and the matrix contains counts corresponding to the number of times each OTU is observed in each sample. With respect to metagenome data, this format would be used to represent metagenome tables: the observations in this case might correspond to SEED subsystems, and the matrix would contain counts corresponding to the number of times each subsystem is observed in each metagenome. Similarly, with respect to genome data, this format may be used to represent a set of genomes: the observations in this case again might correspond to SEED subsystems, and the counts would correspond to the number of times each subsystem is observed in each genome. WWW: http://biom-format.org/ PR: 209193 Submitted by: Joseph Mingrone
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/py-biom-format/Makefile26
-rw-r--r--biology/py-biom-format/distinfo2
-rw-r--r--biology/py-biom-format/pkg-descr19
4 files changed, 48 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index d8ff8900e298..97cdac5ece8c 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -80,6 +80,7 @@
SUBDIR += primer3
SUBDIR += protomol
SUBDIR += psi88
+ SUBDIR += py-biom-format
SUBDIR += py-biopython
SUBDIR += pycogent
SUBDIR += pyfasta
diff --git a/biology/py-biom-format/Makefile b/biology/py-biom-format/Makefile
new file mode 100644
index 000000000000..adb20e4c7484
--- /dev/null
+++ b/biology/py-biom-format/Makefile
@@ -0,0 +1,26 @@
+# Created by: Joseph Mingrone <jrm@ftfl.ca>
+# $FreeBSD$
+
+PORTNAME= biom-format
+PORTVERSION= 2.1.5
+CATEGORIES= biology python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jrm@ftfl.ca
+COMMENT= Biological Observation Matrix (BIOM) Format Project
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} ${PYTHON_PKGNAMEPREFIX}h5py>0:science/py-h5py
+
+USE_GITHUB= yes
+GH_ACCOUNT= biocore
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/biom/*.so
+
+.include <bsd.port.mk>
diff --git a/biology/py-biom-format/distinfo b/biology/py-biom-format/distinfo
new file mode 100644
index 000000000000..50be5f77ff2b
--- /dev/null
+++ b/biology/py-biom-format/distinfo
@@ -0,0 +1,2 @@
+SHA256 (biocore-biom-format-2.1.5_GH0.tar.gz) = e808db612291536e3ca2297c6d72b99154a324fb55fb8898baabc71ceee045d8
+SIZE (biocore-biom-format-2.1.5_GH0.tar.gz) = 11963101
diff --git a/biology/py-biom-format/pkg-descr b/biology/py-biom-format/pkg-descr
new file mode 100644
index 000000000000..2b0a35032361
--- /dev/null
+++ b/biology/py-biom-format/pkg-descr
@@ -0,0 +1,19 @@
+The BIOM file format (canonically pronounced biome) is designed to be a
+general-use format for representing biological sample by observation contingency
+tables. BIOM is a recognized standard for the Earth Microbiome Project and is a
+Genomics Standards Consortium supported project.
+
+The BIOM format is designed for general use in broad areas of comparative
+-omics. For example, in marker-gene surveys, the primary use of this format is
+to represent OTU tables: the observations in this case are OTUs and the matrix
+contains counts corresponding to the number of times each OTU is observed in
+each sample. With respect to metagenome data, this format would be used to
+represent metagenome tables: the observations in this case might correspond to
+SEED subsystems, and the matrix would contain counts corresponding to the number
+of times each subsystem is observed in each metagenome. Similarly, with respect
+to genome data, this format may be used to represent a set of genomes: the
+observations in this case again might correspond to SEED subsystems, and the
+counts would correspond to the number of times each subsystem is observed in
+each genome.
+
+WWW: http://biom-format.org