aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2016-02-26 21:03:05 +0800
committerwen <wen@FreeBSD.org>2016-02-26 21:03:05 +0800
commit7363d6aa7509b6d0d91ae58170bc4d6dd450b285 (patch)
tree98bb5f435f0778918e9e8edd2097768285785f84 /biology
parent6fa07c1c78a51d200c9572cd920e2e576aeb3ddb (diff)
downloadfreebsd-ports-gnome-7363d6aa7509b6d0d91ae58170bc4d6dd450b285.tar.gz
freebsd-ports-gnome-7363d6aa7509b6d0d91ae58170bc4d6dd450b285.tar.zst
freebsd-ports-gnome-7363d6aa7509b6d0d91ae58170bc4d6dd450b285.zip
- Update to 3.2.0
- Update pkg-descr PR: 205890 Submitted by: tkato432@yahoo.com
Diffstat (limited to 'biology')
-rw-r--r--biology/phyml/Makefile54
-rw-r--r--biology/phyml/distinfo6
-rw-r--r--biology/phyml/pkg-descr36
3 files changed, 62 insertions, 34 deletions
diff --git a/biology/phyml/Makefile b/biology/phyml/Makefile
index d5f3d9ed2293..4d512f5145dc 100644
--- a/biology/phyml/Makefile
+++ b/biology/phyml/Makefile
@@ -2,31 +2,59 @@
# $FreeBSD$
PORTNAME= phyml
-PORTVERSION= 20121109
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.2.0
+PORTEPOCH= 1
CATEGORIES= biology
-MASTER_SITES= GOOGLE_CODE
-DISTNAME= ${PORTNAME}-20120412
-DIST_SUBDIR= ${PORTNAME}
-
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= ${PORTVERSION}.patch
-PATCH_DIST_STRIP= -p4
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple, fast, and accurate algorithm to estimate large phylogenies
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-PATCH_WRKSRC= ${WRKSRC}/src
+USE_GITHUB= yes
+GH_ACCOUNT= stephaneguindon
-USES= autoreconf
+USES= autoreconf libtool pkgconfig
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-beagle
+
+PORTDOCS= *
+PORTEXAMPLES= *
+PLIST_FILES= bin/phyml${BIN_SUFFIX}
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_RADIO= MPI
+OPTIONS_RADIO_MPI= MPICH2 OPENMPI
+
+MPICH2_LIB_DEPENDS= libmpich.so:${PORTSDIR}/net/mpich2
+MPICH2_MAKE_ARGS= CC="${LOCALBASE}/bin/mpicc"
+OPENMPI_LIB_DEPENDS= libmpi.so:${PORTSDIR}/net/openmpi
+OPENMPI_MAKE_ARGS= CC="${LOCALBASE}/mpi/openmpi/bin/mpicc"
-PLIST_FILES= bin/phyml
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMPICH2} || ${PORT_OPTIONS:MOPENMPI}
+CONFIGURE_ARGS+= --enable-mpi
+BIN_SUFFIX= -mpi
+.else
+CONFIGURE_ARGS+= --disable-mpi
+BIN_SUFFIX= # none
+.endif
post-patch:
@${REINPLACE_CMD} -e \
- '/^AC_INIT/s|,esyscmd.*,|,[${PORTVERSION}],| ; \
- s|-O2 -msse|$${CFLAGS}|' ${WRKSRC}/configure.ac
+ 's|-O2 .* $${ARCH_flag}|$${CFLAGS}|' ${WRKSRC}/configure.ac
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${INSTALL_DATA} *.pdf \
+ ${STAGEDIR}${DOCSDIR})
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . \
+ ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/biology/phyml/distinfo b/biology/phyml/distinfo
index c588175155a7..c8d91b69279d 100644
--- a/biology/phyml/distinfo
+++ b/biology/phyml/distinfo
@@ -1,4 +1,2 @@
-SHA256 (phyml/phyml-20120412.tar.gz) = a43e51534a1ae2d1ee4c94ced3a1855813ff4872a6c9c2b83b369ddb71198417
-SIZE (phyml/phyml-20120412.tar.gz) = 4089133
-SHA256 (phyml/20121109.patch) = 3aa8bebd0ff78a553795ddda512ef1c7542d1e3c90c1da61c7125c304f6caa2c
-SIZE (phyml/20121109.patch) = 11016
+SHA256 (stephaneguindon-phyml-v3.2.0_GH0.tar.gz) = 9fec8fc26e69cad8d58bf2c9433b531754e4f026dc3464d07958b6c824783fde
+SIZE (stephaneguindon-phyml-v3.2.0_GH0.tar.gz) = 1239843
diff --git a/biology/phyml/pkg-descr b/biology/phyml/pkg-descr
index 4e2aa57579c7..221eaa774c84 100644
--- a/biology/phyml/pkg-descr
+++ b/biology/phyml/pkg-descr
@@ -1,18 +1,20 @@
-PhyML is a software that estimates maximum likelihood phylogenies from
-alignments of nucleotide or amino acid sequences. It provides a wide range of
-options that were designed to facilitate standard phylogenetic analyses. The
-main strengths of PhyML lies in the large number of substitution models coupled
-to various options to search the space of phylogenetic tree topologies, going
-from very fast and efficient methods to slower but generally more accurate
-approaches. It also implements two methods to evaluate branch supports in a
-sound statistical framework (the non-parametric bootstrap and the approximate
-likelihood ratio test). PhyML was designed to process moderate to large data
-sets. In theory, alignments with up to 4,000 sequences 2,000,000 character-long
-can analyzed. In practice however, the amount of memory required to process a
-data set is proportional of the product of the number of sequences by their
-length. Hence, a large number of sequences can only be processed provided that
-they are short. Also, PhyML can handle long sequences provided that they are
-not numerous. With most standard personal computers, the "comfort zone" for
-PhyML generally lies around 3 to 500 sequences less than 2,000 character long.
+PhyML is a software that estimates maximum likelihood phylogenies from
+alignments of nucleotide or amino acid sequences. It provides a wide
+range of options that were designed to facilitate standard phylogenetic
+analyses. The main strengths of PhyML lies in the large number of
+substitution models coupled to various options to search the space of
+phylogenetic tree topologies, going from very fast and efficient methods
+to slower but generally more accurate approaches. It also implements two
+methods to evaluate branch supports in a sound statistical framework
+(the non-parametric bootstrap and the approximate likelihood ratio
+test). PhyML was designed to process moderate to large data sets. In
+theory, alignments with up to 4,000 sequences 2,000,000 character-long
+can analyzed. In practice however, the amount of memory required to
+process a data set is proportional of the product of the number of
+sequences by their length. Hence, a large number of sequences can only
+be processed provided that they are short. Also, PhyML can handle long
+sequences provided that they are not numerous. With most standard
+personal computers, the "comfort zone" for PhyML generally lies around 3
+to 500 sequences less than 2,000 character long.
-WWW: http://code.google.com/p/phyml/
+WWW: https://github.com/stephaneguindon/phyml/