aboutsummaryrefslogtreecommitdiffstats
path: root/cad/adms/Makefile
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-07-30 05:10:26 +0800
committeritetcu <itetcu@FreeBSD.org>2006-07-30 05:10:26 +0800
commit2b1331f86c9c9909653cfe77eefc58539e92a66e (patch)
treefa42622bb741fc941bf97c8f1898cec8da3c8ad4 /cad/adms/Makefile
parentb50edc880585797147af411c0e8dfe679ef54896 (diff)
downloadfreebsd-ports-gnome-2b1331f86c9c9909653cfe77eefc58539e92a66e.tar.gz
freebsd-ports-gnome-2b1331f86c9c9909653cfe77eefc58539e92a66e.tar.zst
freebsd-ports-gnome-2b1331f86c9c9909653cfe77eefc58539e92a66e.zip
ADMS is a code generator that converts electrical compact device models
specified in high-level description language into ready-to-compile c code for the API of spice simulators. WWW: http://mot-adms.sourceforge.net/ PR: ports/101014 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Diffstat (limited to 'cad/adms/Makefile')
-rw-r--r--cad/adms/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/cad/adms/Makefile b/cad/adms/Makefile
new file mode 100644
index 000000000000..6123fe89a695
--- /dev/null
+++ b/cad/adms/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: adms
+# Date created: 2006-07-29
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= adms
+PORTVERSION= 2.2.4
+CATEGORIES= cad
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=mot-adms
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= A model generator for SPICE simulators
+
+USE_GMAKE= yes
+USE_GNOME= glib20 pkgconfig
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_GCC= 3.2+
+
+.include <bsd.port.mk>