aboutsummaryrefslogtreecommitdiffstats
path: root/cad/brlcad
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-11-01 14:35:53 +0800
committerrafan <rafan@FreeBSD.org>2006-11-01 14:35:53 +0800
commit8689f4e5b6e5342932bdc6204f082505b6237420 (patch)
tree1982ac58750e13dba7e9aca0bf3b4c7080bf4c73 /cad/brlcad
parent1c9ca663a5e723bab22b84fbb16607eff0b3e7b5 (diff)
downloadfreebsd-ports-gnome-8689f4e5b6e5342932bdc6204f082505b6237420.tar.gz
freebsd-ports-gnome-8689f4e5b6e5342932bdc6204f082505b6237420.tar.zst
freebsd-ports-gnome-8689f4e5b6e5342932bdc6204f082505b6237420.zip
- Update to 7.8.4
PR: ports/104545 Submitted by: Erik Greenwald <erik at smluc.org> (maintainer)
Diffstat (limited to 'cad/brlcad')
-rw-r--r--cad/brlcad/Makefile17
-rw-r--r--cad/brlcad/distinfo6
-rw-r--r--cad/brlcad/files/patch-src_liboptical_Makefile.in10
-rw-r--r--cad/brlcad/pkg-plist30
4 files changed, 43 insertions, 20 deletions
diff --git a/cad/brlcad/Makefile b/cad/brlcad/Makefile
index 0020ab6b551e..326ecca98b10 100644
--- a/cad/brlcad/Makefile
+++ b/cad/brlcad/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= brlcad
-PORTVERSION= 7.8.2
+PORTVERSION= 7.8.4
CATEGORIES= cad
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= brlcad
@@ -24,13 +24,14 @@ USE_GMAKE= yes
PREFIX?= ${LOCALBASE}/${PORTNAME}
GNU_CONFIGURE= yes
NO_MTREE= yes
-INSTALLS_SHLIB= yes # Not really useful, but pet portlint
+USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.4
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS+=--with-libs="-lpng ${EXTRA_LIBS}" --program-transform-name="" \
- --disable-jove-build
+CONFIGURE_ARGS+=--enable-tcl-build --enable-tk-build --disable-adrt-build \
+ --with-libs="-lpng ${EXTRA_LIBS}" --program-transform-name="" \
+ --disable-jove-build
PLIST_SUB+= PORTVERSION=${PORTVERSION}
MAN1= alias-pix.1 all_sf.1 anim_cascade.1 anim_fly.1 anim_hardtrack.1 \
@@ -69,8 +70,8 @@ MAN1= alias-pix.1 all_sf.1 anim_cascade.1 anim_fly.1 anim_hardtrack.1 \
rtg3.1 rthide.1 rtpp.1 rtrange.1 rtray.1 rtregis.1 rtscale.1 rtshot.1 \
rttherm.1 rtwalk.1 rtweight.1 rtxray.1 scriptsort.1 secpass.1 \
shapefact.1 showshot.1 showtherm.1 ssamp-bw.1 stl-g.1 sun-pix.1 \
- tabinterp.1 tabsub.1 tankill-g.1 tclsh.1 terrain.1 ug-g.1 vas4.1 \
- vdeck.1 viewpoint-g.1 wavelet.1 wish.1
+ tabinterp.1 tabsub.1 tankill-g.1 tclsh.1 terrain.1 vas4.1 vdeck.1 \
+ viewpoint-g.1 wavelet.1 wish.1
MAN3= 3DBorder.3 Access.3 AddErrInfo.3 AddOption.3 Alloc.3 AllowExc.3 \
AppInit.3 AssocData.3 Async.3 BackgdErr.3 Backslash.3 BindTable.3 \
@@ -158,9 +159,7 @@ OPTIONS= OPTIMIZATION "Try building with optimizations" on
.include <bsd.port.pre.mk>
-.if ${ARCH} == sparc64
EXTRA_LIBS= ${PTHREAD_LIBS}
-.endif
# we only run on i386 and amd64 release 5+
.if ${OSVERSION} < 500000
diff --git a/cad/brlcad/distinfo b/cad/brlcad/distinfo
index d4f2c1ef5d2a..2ad69dcd0c37 100644
--- a/cad/brlcad/distinfo
+++ b/cad/brlcad/distinfo
@@ -1,3 +1,3 @@
-MD5 (brlcad-7.8.2.tar.bz2) = 38854509545cb4a1b037d1ac47aac731
-SHA256 (brlcad-7.8.2.tar.bz2) = 6e7d17f57383ba8830aedf126a205bed46f4bbbc857118eb8021f706720711c6
-SIZE (brlcad-7.8.2.tar.bz2) = 19955186
+MD5 (brlcad-7.8.4.tar.bz2) = 01539c0045e8f6159d6aeea374641cde
+SHA256 (brlcad-7.8.4.tar.bz2) = 6b091015371f13a3898ec7f26dd9c517084f2b2c5db61e1f16a30853aac49c22
+SIZE (brlcad-7.8.4.tar.bz2) = 19954301
diff --git a/cad/brlcad/files/patch-src_liboptical_Makefile.in b/cad/brlcad/files/patch-src_liboptical_Makefile.in
index 65dee7146e6b..510027a7168d 100644
--- a/cad/brlcad/files/patch-src_liboptical_Makefile.in
+++ b/cad/brlcad/files/patch-src_liboptical_Makefile.in
@@ -1,11 +1,11 @@
---- src/liboptical/Makefile.in.orig Tue Apr 11 00:42:03 2006
-+++ src/liboptical/Makefile.in Fri Apr 14 01:13:22 2006
-@@ -436,7 +436,7 @@
-
+--- ./src/liboptical/Makefile.in.orig Tue Oct 17 04:50:16 2006
++++ ./src/liboptical/Makefile.in Tue Oct 31 18:48:48 2006
+@@ -277,7 +277,7 @@
# convenience library, must NOT be set to static in here
noinst_LTLIBRARIES = librtms.la
+
-librtms_la_CFLAGS = -DRT_MULTISPECTRAL
+librtms_la_CFLAGS = -DRT_MULTISPECTRAL -fPIC
librtms_la_LIBADD = \
- ${LIBRT} \
+ ${RT} \
${BN} \
diff --git a/cad/brlcad/pkg-plist b/cad/brlcad/pkg-plist
index 125f8e9ad635..5c9e54de4a85 100644
--- a/cad/brlcad/pkg-plist
+++ b/cad/brlcad/pkg-plist
@@ -62,6 +62,7 @@ bin/c-d
bin/cad_boundp
bin/cad_parea
bin/cadbug.sh
+bin/canonize
bin/cat-fb
bin/cell-fb
bin/chan_add
@@ -107,6 +108,7 @@ bin/euclid_format
bin/euclid_unformat
bin/f-d
bin/f-i
+bin/facetall.sh
bin/fast4-g
bin/fb-bw
bin/fb-cmap
@@ -175,6 +177,8 @@ bin/ihist
bin/imgdims
bin/imod
bin/indent.sh
+bin/ipuscan
+bin/ipustat
bin/ir-X
bin/ir-sgi
bin/irdisp
@@ -183,6 +187,7 @@ bin/jack-g
bin/kurt
bin/lgt
bin/loop
+bin/lowp
bin/mac-pix
bin/mged
bin/mged.sh
@@ -215,6 +220,7 @@ bin/pix-alias
bin/pix-bw
bin/pix-bw3
bin/pix-fb
+bin/pix-ipu
bin/pix-orle
bin/pix-png
bin/pix-ppm
@@ -284,6 +290,7 @@ bin/plstat
bin/ply-g
bin/png-bw
bin/png-fb
+bin/png-ipu
bin/png-pix
bin/png_info
bin/polar-fb
@@ -453,6 +460,8 @@ include/brlcad/dm-ogl.h
include/brlcad/dm-pex.h
include/brlcad/dm-plot.h
include/brlcad/dm-ps.h
+include/brlcad/dm-tk.h
+include/brlcad/dm-wgl.h
include/brlcad/dm.h
include/brlcad/dm_color.h
include/brlcad/dm_xvars.h
@@ -460,7 +469,6 @@ include/brlcad/exit_status.h
include/brlcad/fb.h
include/brlcad/fbio.h
include/brlcad/fbserv_obj.h
-include/brlcad/forms.h
include/brlcad/itcl.h
include/brlcad/itclDecls.h
include/brlcad/itclInt.h
@@ -553,13 +561,16 @@ lib/blt2.4/dd_protocols/dd-color.tcl
lib/blt2.4/dd_protocols/dd-file.tcl
lib/blt2.4/dd_protocols/dd-number.tcl
lib/blt2.4/dd_protocols/dd-text.tcl
+lib/blt2.4/dd_protocols/tclIndex
lib/blt2.4/dnd.tcl
lib/blt2.4/dragdrop.tcl
lib/blt2.4/graph.tcl
lib/blt2.4/hierbox.tcl
lib/blt2.4/hiertable.tcl
+lib/blt2.4/pkgIndex.tcl
lib/blt2.4/tabnotebook.tcl
lib/blt2.4/tabset.tcl
+lib/blt2.4/tclIndex
lib/blt2.4/treeview.tcl
lib/blt2.4/treeview.xbm
lib/blt2.4/treeview_m.xbm
@@ -989,6 +1000,7 @@ lib/tkimg.a
lib/tkimg.la
lib/tkimg.so
lib/tkimg.so.0
+man/man1/canonize.1
%%DATADIR%%/%%PORTVERSION%%/AUTHORS
%%DATADIR%%/%%PORTVERSION%%/COPYING
%%DATADIR%%/%%PORTVERSION%%/HACKING
@@ -1027,18 +1039,21 @@ lib/tkimg.so.0
%%DATADIR%%/%%PORTVERSION%%/db/star.g
%%DATADIR%%/%%PORTVERSION%%/db/tank_car.g
%%DATADIR%%/%%PORTVERSION%%/db/terra.g
-%%DATADIR%%/%%PORTVERSION%%/db/truck.g
%%DATADIR%%/%%PORTVERSION%%/db/toyjeep.g
+%%DATADIR%%/%%PORTVERSION%%/db/truck.g
%%DATADIR%%/%%PORTVERSION%%/db/wave.g
%%DATADIR%%/%%PORTVERSION%%/db/woodsman.g
%%DATADIR%%/%%PORTVERSION%%/db/world.g
%%DATADIR%%/%%PORTVERSION%%/db/xmp.g
+%%DATADIR%%/%%PORTVERSION%%/doc/IDEAS
+%%DATADIR%%/%%PORTVERSION%%/doc/PROJECTS
%%DATADIR%%/%%PORTVERSION%%/doc/README.AIX
%%DATADIR%%/%%PORTVERSION%%/doc/README.BSD
%%DATADIR%%/%%PORTVERSION%%/doc/README.IRIX
%%DATADIR%%/%%PORTVERSION%%/doc/README.Linux
%%DATADIR%%/%%PORTVERSION%%/doc/README.MacOSX
%%DATADIR%%/%%PORTVERSION%%/doc/README.Solaris
+%%DATADIR%%/%%PORTVERSION%%/doc/README.VAX
%%DATADIR%%/%%PORTVERSION%%/doc/README.Windows
%%DATADIR%%/%%PORTVERSION%%/doc/anim.txt
%%DATADIR%%/%%PORTVERSION%%/doc/archer_ack.txt
@@ -1059,6 +1074,7 @@ lib/tkimg.so.0
%%DATADIR%%/%%PORTVERSION%%/doc/mk.tr
%%DATADIR%%/%%PORTVERSION%%/doc/movie.txt
%%DATADIR%%/%%PORTVERSION%%/doc/old-mged.tr
+%%DATADIR%%/%%PORTVERSION%%/doc/pad_file.xml
%%DATADIR%%/%%PORTVERSION%%/doc/pkg.tr
%%DATADIR%%/%%PORTVERSION%%/doc/regions.txt
%%DATADIR%%/%%PORTVERSION%%/doc/rounding.txt
@@ -1296,7 +1312,6 @@ lib/tkimg.so.0
%%DATADIR%%/%%PORTVERSION%%/html/manuals/mged/bool.gif
%%DATADIR%%/%%PORTVERSION%%/html/manuals/mged/brlcad_glossary.html
%%DATADIR%%/%%PORTVERSION%%/html/manuals/mged/brlcad_solids.html
-%%DATADIR%%/%%PORTVERSION%%/html/manuals/mged/bugs
%%DATADIR%%/%%PORTVERSION%%/html/manuals/mged/build_def_index.sh
%%DATADIR%%/%%PORTVERSION%%/html/manuals/mged/cmd_line_ed.html
%%DATADIR%%/%%PORTVERSION%%/html/manuals/mged/concl.html
@@ -1364,6 +1379,9 @@ lib/tkimg.so.0
%%DATADIR%%/%%PORTVERSION%%/pix/star.pix
%%DATADIR%%/%%PORTVERSION%%/pix/world.log
%%DATADIR%%/%%PORTVERSION%%/pix/world.pix
+%%DATADIR%%/%%PORTVERSION%%/plugins/archer/Command/README
+%%DATADIR%%/%%PORTVERSION%%/plugins/archer/Core/README
+%%DATADIR%%/%%PORTVERSION%%/plugins/archer/Utility/README
%%DATADIR%%/%%PORTVERSION%%/plugins/archer/Wizards/tankwizardIA.tcl
%%DATADIR%%/%%PORTVERSION%%/plugins/archer/Wizards/tankwizardIA/TankWizardIA.tcl
%%DATADIR%%/%%PORTVERSION%%/plugins/archer/Wizards/tankwizardIA/images/tank.png
@@ -1404,6 +1422,7 @@ lib/tkimg.so.0
%%DATADIR%%/%%PORTVERSION%%/tclscripts/archer/Plugin.tcl
%%DATADIR%%/%%PORTVERSION%%/tclscripts/archer/RhcEditFrame.tcl
%%DATADIR%%/%%PORTVERSION%%/tclscripts/archer/RpcEditFrame.tcl
+%%DATADIR%%/%%PORTVERSION%%/tclscripts/archer/ShaderEdit.tcl
%%DATADIR%%/%%PORTVERSION%%/tclscripts/archer/SketchEditFrame.tcl
%%DATADIR%%/%%PORTVERSION%%/tclscripts/archer/SphereEditFrame.tcl
%%DATADIR%%/%%PORTVERSION%%/tclscripts/archer/TgcEditFrame.tcl
@@ -1653,7 +1672,9 @@ lib/tkimg.so.0
%%DATADIR%%/%%PORTVERSION%%/tclscripts/mged/editmenu.tcl
%%DATADIR%%/%%PORTVERSION%%/tclscripts/mged/editobj.tcl
%%DATADIR%%/%%PORTVERSION%%/tclscripts/mged/eobjmenu.tcl
+%%DATADIR%%/%%PORTVERSION%%/tclscripts/mged/expand_comb.tcl
%%DATADIR%%/%%PORTVERSION%%/tclscripts/mged/extract.tcl
+%%DATADIR%%/%%PORTVERSION%%/tclscripts/mged/facetize_all_regions.tcl
%%DATADIR%%/%%PORTVERSION%%/tclscripts/mged/font.tcl
%%DATADIR%%/%%PORTVERSION%%/tclscripts/mged/g2asc.tcl
%%DATADIR%%/%%PORTVERSION%%/tclscripts/mged/garbage_collect.tcl
@@ -1867,6 +1888,9 @@ lib/tkimg.so.0
@dirrm %%DATADIR%%/%%PORTVERSION%%/plugins/archer/Wizards/tankwizardIA/images
@dirrm %%DATADIR%%/%%PORTVERSION%%/plugins/archer/Wizards/tankwizardIA
@dirrm %%DATADIR%%/%%PORTVERSION%%/plugins/archer/Wizards
+@dirrm %%DATADIR%%/%%PORTVERSION%%/plugins/archer/Utility
+@dirrm %%DATADIR%%/%%PORTVERSION%%/plugins/archer/Core
+@dirrm %%DATADIR%%/%%PORTVERSION%%/plugins/archer/Command
@dirrm %%DATADIR%%/%%PORTVERSION%%/plugins/archer
@dirrm %%DATADIR%%/%%PORTVERSION%%/plugins
@dirrm %%DATADIR%%/%%PORTVERSION%%/pix