aboutsummaryrefslogtreecommitdiffstats
path: root/cad/brlcad
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2008-07-14 05:17:17 +0800
committerlippe <lippe@FreeBSD.org>2008-07-14 05:17:17 +0800
commit757e3fd3afee09ed59a0d50b09f6a1fb3cdb468c (patch)
tree92d5b4bced8cb13cf769aa55316a19b1e31ccd2a /cad/brlcad
parent96430ad14012839f29e655c885fda55de9e57cf1 (diff)
downloadfreebsd-ports-gnome-757e3fd3afee09ed59a0d50b09f6a1fb3cdb468c.tar.gz
freebsd-ports-gnome-757e3fd3afee09ed59a0d50b09f6a1fb3cdb468c.tar.zst
freebsd-ports-gnome-757e3fd3afee09ed59a0d50b09f6a1fb3cdb468c.zip
- Mark as BROKEN on -CURRENT.
- Add regression-test. PR: ports/124733 Submitted by: "Pedro F. Giffuni" <pfgshield-freebsd@yahoo.com> Reviewed by: lippe Approved by: gabor (mentor, implicit)
Diffstat (limited to 'cad/brlcad')
-rw-r--r--cad/brlcad/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/cad/brlcad/Makefile b/cad/brlcad/Makefile
index c0e42f7add27..75d6c5c9d2c4 100644
--- a/cad/brlcad/Makefile
+++ b/cad/brlcad/Makefile
@@ -113,6 +113,10 @@ OPTIONS= OPTIMIZATION "Build with optimizations" on
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 800032
+BROKEN= does not compile
+.endif
+
EXTRA_LIBS= ${PTHREAD_LIBS}
.ifdef WITH_OPTIMIZATION
@@ -131,4 +135,7 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/mged.sh ${PREFIX}/bin/mged.sh
${LN} -s ${PREFIX}/bin/mged.sh ${LOCALBASE}/bin/mged.sh
+regression-test: build
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} test)
+
.include <bsd.port.post.mk>