aboutsummaryrefslogtreecommitdiffstats
path: root/cad/cider/Makefile
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2015-03-23 03:21:43 +0800
committerbdrewery <bdrewery@FreeBSD.org>2015-03-23 03:21:43 +0800
commitadf91cdad573b4d483da2e3c1fc0086d95004975 (patch)
tree2342f33cec228452866c610b31bda75d04c0e162 /cad/cider/Makefile
parent4d1b76aa0d830600986397e674d49159589fa0e9 (diff)
downloadfreebsd-ports-gnome-adf91cdad573b4d483da2e3c1fc0086d95004975.tar.gz
freebsd-ports-gnome-adf91cdad573b4d483da2e3c1fc0086d95004975.tar.zst
freebsd-ports-gnome-adf91cdad573b4d483da2e3c1fc0086d95004975.zip
Unreak.
This does not require fmake. It just has bad return values which don't build with clang. The build is using 'make -k' so the errors are ignored. I did not fix that though.
Diffstat (limited to 'cad/cider/Makefile')
-rw-r--r--cad/cider/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/cad/cider/Makefile b/cad/cider/Makefile
index 7c1adddc8fd4..7b96f0e16761 100644
--- a/cad/cider/Makefile
+++ b/cad/cider/Makefile
@@ -18,16 +18,9 @@ USE_XORG= xt xaw xmu
OPTIONS_DEFINE= EXAMPLES
-.include <bsd.port.options.mk>
+CFLAGS+= -Wno-return-type
-.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1000100
-# cider has a generated makefile that is passed to make via stdin.
-# bmake doesn't understand its generic static library targets, but
-# continues on failure. The result is several programs aren't built.
-# Using USE+=fmake even with patching won't fix it on FreeBSD 10. make
-# must be hardcoded somewhere because fmake ends up calling make.
-BROKEN= Will not build with bmake and USES=fmake will not solve the issue
-.endif
+.include <bsd.port.options.mk>
pre-patch:
@${CP} -f ${WRKSRC}/spice/common/lib/helpdir/spice.txt \
@@ -44,8 +37,8 @@ post-patch:
@${CP} -f ${FILESDIR}/FreeBSD ${WRKSRC}/cider/common/conf
do-build:
- @(cd ${WRKSRC}/spice/common && ${SETENV} ${MAKE_ENV} ${MAKE_CMD})
- @(cd ${WRKSRC}/cider/common && ${SETENV} ${MAKE_ENV} ${MAKE_CMD})
+ @(cd ${WRKSRC}/spice/common && ${SETENV} ${MAKE_ENV} ${MAKE_CMD}) && \
+ (cd ${WRKSRC}/cider/common && ${SETENV} ${MAKE_ENV} ${MAKE_CMD})
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/spice3/helpdir \