aboutsummaryrefslogtreecommitdiffstats
path: root/cad/fidocadj/Makefile
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2012-07-17 00:46:10 +0800
committernivit <nivit@FreeBSD.org>2012-07-17 00:46:10 +0800
commit4ef4f27ad9de3b0c5ade62181dbf2906f694f956 (patch)
treedee435a545524725fc00942c750b71754ec48193 /cad/fidocadj/Makefile
parentc0d178957b4d4ce682ecd3e2d2c88fa7065e4b03 (diff)
downloadfreebsd-ports-gnome-4ef4f27ad9de3b0c5ade62181dbf2906f694f956.tar.gz
freebsd-ports-gnome-4ef4f27ad9de3b0c5ade62181dbf2906f694f956.tar.zst
freebsd-ports-gnome-4ef4f27ad9de3b0c5ade62181dbf2906f694f956.zip
- Update to 0.24
- Set a different MASTER_SITE_SUBDIR for source and docs - Convert to the new options framework
Diffstat (limited to 'cad/fidocadj/Makefile')
-rw-r--r--cad/fidocadj/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/cad/fidocadj/Makefile b/cad/fidocadj/Makefile
index 6a781bfe3e27..5111d71767e2 100644
--- a/cad/fidocadj/Makefile
+++ b/cad/fidocadj/Makefile
@@ -6,15 +6,12 @@
#
PORTNAME= fidocadj
-PORTVERSION= 0.23.7
+PORTVERSION= 0.24
#PORTREVISION= 0
CATEGORIES= cad
-MASTER_SITES= SF
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTFILES= ${PORTNAME}.jar
-.if !defined(NOPORTDOCS)
-DISTFILES+= ${PORTNAME}_manual_en.pdf
-.endif
+MASTER_SITES= SF:src,docs
+MASTER_SITE_SUBDIR= ${PORTNAME}/:src ${PORTNAME}/manuals/:docs
+DISTFILES= ${PORTNAME}.jar:src
EXTRACT_ONLY=
MAINTAINER= nivit@FreeBSD.org
@@ -31,15 +28,25 @@ SUB_FILES= ${PORTNAME}.sh
JAVA_VERSION= 1.5+
USE_JAVA= yes
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
FDCJ_MANUAL= ${PORTNAME}_manual_en.pdf
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
${MKDIR} ${DATADIR}; \
${INSTALL_DATA} ${DISTDIR}/${PORTNAME}.jar ${DATADIR}/
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR} && \
${INSTALL_DATA} ${DISTDIR}/${FDCJ_MANUAL} ${DOCSDIR}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+DISTFILES+= ${PORTNAME}_manual_en.pdf:docs
+.endif
+
+.include <bsd.port.post.mk>