aboutsummaryrefslogtreecommitdiffstats
path: root/cad/freecad
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-09-24 19:06:57 +0800
committertijl <tijl@FreeBSD.org>2016-09-24 19:06:57 +0800
commit066998172e46dd08df392ecd35af710e3dd3da2a (patch)
treee47126c6c357762b62f9e5736c3d27d12948e676 /cad/freecad
parent49712f6fc0b0b344ad61319c9fe1eefaae4bc422 (diff)
downloadfreebsd-ports-gnome-066998172e46dd08df392ecd35af710e3dd3da2a.tar.gz
freebsd-ports-gnome-066998172e46dd08df392ecd35af710e3dd3da2a.tar.zst
freebsd-ports-gnome-066998172e46dd08df392ecd35af710e3dd3da2a.zip
- Update devel/icu to 57.1.
- Clean up the Makefile. - Follow some upstream recommendations (--with-data-packaging=archive, --disable-renaming, -DICU_NO_USER_DATA_OVERRIDE). - Patch makefiles to install static libraries with INSTALL_DATA so they aren't stripped. - Patch config/mh-bsd-gcc to sync with config/mh-linux-gcc. - Fix endianness detection in ICU. The code wanted to use BYTE_ORDER defined in machine/endian.h, but this isn't visible because ICU is compiled with _XOPEN_SOURCE. Patch the code to use _BYTE_ORDER instead. - Compile ICU with C++11 compiler to enable move constructors. - Patch ICU to fix a problem with atomics in the case of a C++11 compiler without C++11 header <atomic> (like Clang on FreeBSD 9). - Bump all ports that depend on it due to library version change. - Add USES=compiler:c++0x to some ports that pick up -std=c++0x from ICU pkgconfig files. - Add USES=compiler:c++11-lib to graphics/libcdr01 because it also needs a C++11 runtime library now. Add this to all ports that depend on it so their executables load the right libstdc++.so on FreeBSD 9. PR: 205120 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'cad/freecad')
-rw-r--r--cad/freecad/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index 22b358fe968f..07d75d5f7dc7 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -2,6 +2,7 @@
PORTNAME= FreeCAD
DISTVERSION= 0.17.g20160907
+PORTREVISION= 1
CATEGORIES= cad
MAINTAINER= pfg@FreeBSD.org
@@ -31,7 +32,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
USE_GITHUB= yes
GH_TAGNAME= 1ed3562
-USES= compiler:c++11-lang cmake:outsource jpeg python localbase
+USES= compiler:c++11-lib cmake:outsource jpeg python localbase
USE_XORG= ice sm x11 xext xt
USE_GL= gl glu
USE_QT4= qmake_build corelib gui moc_build network opengl rcc_build \