aboutsummaryrefslogtreecommitdiffstats
path: root/cad/freecad
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-12-12 00:54:20 +0800
committerantoine <antoine@FreeBSD.org>2017-12-12 00:54:20 +0800
commit8d3f9e637bedbbfa8df328bb37f953531d0dac4d (patch)
tree1bd1a4476491ef32afe3f13e01c9056a28435cc3 /cad/freecad
parent25ca86f1d02f85687a502b229a2837c93974fbe2 (diff)
downloadfreebsd-ports-gnome-8d3f9e637bedbbfa8df328bb37f953531d0dac4d.tar.gz
freebsd-ports-gnome-8d3f9e637bedbbfa8df328bb37f953531d0dac4d.tar.zst
freebsd-ports-gnome-8d3f9e637bedbbfa8df328bb37f953531d0dac4d.zip
- Those ports fail to build with python3
- Add some explicit FLAVOR to dependencies where needed
Diffstat (limited to 'cad/freecad')
-rw-r--r--cad/freecad/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index a917dd1eec88..9a14e90f3269 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= pyside-rcc:devel/pyside-tools \
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libfreetype.so:print/freetype2 \
libboost_python.so:devel/boost-python-libs \
- libpyside-python2.7.so:devel/pyside \
+ libpyside-python2.7.so:devel/pyside@${PY_FLAVOR} \
libCoin.so:graphics/Coin \
libpng.so:graphics/png \
libtiff.so:graphics/tiff \
@@ -29,10 +29,10 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libmed.so:french/med \
libshiboken-${PYTHON_VERSION}.so:devel/shiboken \
libhdf5.so:science/hdf5
-RUN_DEPENDS= pivy>0:graphics/py-pivy
+RUN_DEPENDS= pivy>0:graphics/py-pivy@${PY_FLAVOR}
USES= dos2unix compiler:c++11-lib cmake:outsource fortran jpeg \
- python localbase
+ python:2.7 localbase
USE_XORG= ice sm x11 xext xt
USE_GL= gl glu
USE_QT4= qmake_build corelib gui moc_build network opengl rcc_build \
@@ -58,7 +58,7 @@ GH_TAGNAME= f27617e
OPTIONS_DEFINE= COLLADA
COLLADA_DESC= Install pycollada for Collada files import
-COLLADA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycollada>0:graphics/py-pycollada
+COLLADA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycollada>0:graphics/py-pycollada@${PY_FLAVOR}
DESKTOP_ENTRIES=${PORTNAME} "" "${PREFIX}/FreeCAD/data/freecad.svg" \
${PORTNAME} "Engineering;" false