aboutsummaryrefslogtreecommitdiffstats
path: root/cad/geda-gattrib
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-11-20 23:37:08 +0800
committerkwm <kwm@FreeBSD.org>2010-11-20 23:37:08 +0800
commit3d272740920a1868e8acfed76d6e4c67c331e101 (patch)
tree2a5c0b3f83feeff6b7818d6af84084a526182651 /cad/geda-gattrib
parent16773b885888858d80db86065d33dcf723459cbd (diff)
downloadfreebsd-ports-gnome-3d272740920a1868e8acfed76d6e4c67c331e101.tar.gz
freebsd-ports-gnome-3d272740920a1868e8acfed76d6e4c67c331e101.tar.zst
freebsd-ports-gnome-3d272740920a1868e8acfed76d6e4c67c331e101.zip
Presenting GNOME 2.32.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.32/ This will be the last release of the GNOME 2.x series, mainly a bugfix and bridge release to the first release of the GNOME 3.x series. This release features commits by avl, marcus, mezz and myself. The FreeBSD GNOME Team would like to thank the following contributors and testers for there help with this release: Zane C.B. <vvelox@vvelox.net> romain@ Olaf Seibert <O.Seibert@cs.ru.nl> DomiX Bapt <baptiste.daroussin@gmail.com> jsa@ miwi@ Sergio de Almeida Lenzi <lenzi.sergio@gmail.com> Maxim Samsonov <xors@mne.ru> Kris Moore And pav@ for 2 exp-runs PR: ports/152255 ports/143260 ports/141033 ports/149629 ports/150350 ports/151523 With hat: gnome@
Diffstat (limited to 'cad/geda-gattrib')
-rw-r--r--cad/geda-gattrib/Makefile2
-rw-r--r--cad/geda-gattrib/files/patch-src_gtkitementry_2_2.c28
2 files changed, 29 insertions, 1 deletions
diff --git a/cad/geda-gattrib/Makefile b/cad/geda-gattrib/Makefile
index fd903e379cac..16a6e27adad4 100644
--- a/cad/geda-gattrib/Makefile
+++ b/cad/geda-gattrib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gattrib
PORTVERSION= 1.4.3
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
diff --git a/cad/geda-gattrib/files/patch-src_gtkitementry_2_2.c b/cad/geda-gattrib/files/patch-src_gtkitementry_2_2.c
new file mode 100644
index 000000000000..29d2ae56b635
--- /dev/null
+++ b/cad/geda-gattrib/files/patch-src_gtkitementry_2_2.c
@@ -0,0 +1,28 @@
+--- src/gtkitementry_2_2.c.orig 2010-10-29 19:10:42.000000000 +0200
++++ src/gtkitementry_2_2.c 2010-10-29 19:11:29.000000000 +0200
+@@ -156,7 +156,7 @@ static void gtk_entry_draw_curso
+ static PangoLayout *gtk_entry_ensure_layout (GtkEntry *entry,
+ gboolean include_preedit);
+ static void gtk_entry_queue_draw (GtkEntry *entry);
+-static void gtk_entry_reset_im_context (GtkEntry *entry);
++//static void gtk_entry_reset_im_context (GtkEntry *entry);
+ static void gtk_entry_recompute (GtkEntry *entry);
+ static void gtk_entry_get_cursor_locations (GtkEntry *entry,
+ CursorType type,
+@@ -1830,16 +1830,6 @@ gtk_entry_queue_draw (GtkEntry *entry)
+ }
+
+ static void
+-gtk_entry_reset_im_context (GtkEntry *entry)
+-{
+- if (entry->need_im_reset)
+- {
+- entry->need_im_reset = 0;
+- gtk_im_context_reset (entry->im_context);
+- }
+-}
+-
+-static void
+ gtk_entry_get_cursor_locations (GtkEntry *entry,
+ CursorType type,
+ gint *strong_x,