aboutsummaryrefslogtreecommitdiffstats
path: root/cad/geda-utils/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-10-11 02:38:37 +0800
committerijliao <ijliao@FreeBSD.org>2002-10-11 02:38:37 +0800
commit567c8ce446734666893fafc8762d4313997bd686 (patch)
treeb4042e2d2248ff7f5ac9575822ab07c2fcf51382 /cad/geda-utils/Makefile
parent6527c0095ddb3430e8757a913db98d4778c9b41f (diff)
downloadfreebsd-ports-gnome-567c8ce446734666893fafc8762d4313997bd686.tar.gz
freebsd-ports-gnome-567c8ce446734666893fafc8762d4313997bd686.tar.zst
freebsd-ports-gnome-567c8ce446734666893fafc8762d4313997bd686.zip
add geda-utils
gEDA utilities PR: 43563 Submitted by: bruno <bruno@mail.tinkerbox.org>
Diffstat (limited to 'cad/geda-utils/Makefile')
-rw-r--r--cad/geda-utils/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/cad/geda-utils/Makefile b/cad/geda-utils/Makefile
new file mode 100644
index 000000000000..95ce3603c73c
--- /dev/null
+++ b/cad/geda-utils/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: geda
+# Date created: 4 April 2001
+# Whom: bruno schwander <bruno@tinkerbox.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= utils
+PORTVERSION= 20020825
+CATEGORIES= cad
+MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/devel/${PORTVERSION}/ \
+ http://geda.seul.org/devel/${PORTVERSION}/ \
+ http://www.tinkerbox.org/projects/files/gEDA/
+DISTNAME= geda-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= bruno@tinkerbox.org
+
+BUILD_DEPENDS= gesym-config:${PORTSDIR}/cad/geda-symbols
+LIB_DEPENDS= geda.16:${PORTSDIR}/cad/libgeda \
+ guile.10:${PORTSDIR}/lang/guile
+
+USE_LIBTOOL= yes
+#USE_AUTOCONF= yes
+AUTOCONF= autoconf
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-gdgeda
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>