aboutsummaryrefslogtreecommitdiffstats
path: root/cad/gnucap
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-12-22 21:23:19 +0800
committerijliao <ijliao@FreeBSD.org>2002-12-22 21:23:19 +0800
commitf109d0a9f0034ec3e1d4d50ab46b618d39b8ead4 (patch)
treed4a4f03285fe74d11503ffe7765c2601ab167c18 /cad/gnucap
parent2b335d4b285d871ef50b99984e97d21c87d1efd3 (diff)
downloadfreebsd-ports-gnome-f109d0a9f0034ec3e1d4d50ab46b618d39b8ead4.tar.gz
freebsd-ports-gnome-f109d0a9f0034ec3e1d4d50ab46b618d39b8ead4.tar.zst
freebsd-ports-gnome-f109d0a9f0034ec3e1d4d50ab46b618d39b8ead4.zip
fix build on -current
PR: 46462 Submitted by: Ports Fury
Diffstat (limited to 'cad/gnucap')
-rw-r--r--cad/gnucap/Makefile2
-rw-r--r--cad/gnucap/files/patch-src::xprobe.cc11
2 files changed, 13 insertions, 0 deletions
diff --git a/cad/gnucap/Makefile b/cad/gnucap/Makefile
index ba6b47ad09c5..a0f697dcc6d7 100644
--- a/cad/gnucap/Makefile
+++ b/cad/gnucap/Makefile
@@ -18,6 +18,8 @@ USE_REINPLACE= yes
USE_GMAKE= yes
MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
+CFLAGS+= -DNEEDS_COPY_N
+
post-patch:
.for file in src/Make2.g++ src/Make.aux modelgen/Make.aux
@${REINPLACE_CMD} -e "s|g\+\+|\$$\{CXX\}|g" \
diff --git a/cad/gnucap/files/patch-src::xprobe.cc b/cad/gnucap/files/patch-src::xprobe.cc
new file mode 100644
index 000000000000..9859c8c0ca49
--- /dev/null
+++ b/cad/gnucap/files/patch-src::xprobe.cc
@@ -0,0 +1,11 @@
+--- src/u_xprobe.cc.orig Tue Mar 26 18:20:27 2002
++++ src/u_xprobe.cc Sun Dec 22 09:17:33 2002
+@@ -25,7 +25,7 @@
+ #include "u_opt.h"
+ #include "u_xprobe.h"
+ /*--------------------------------------------------------------------------*/
+-double XPROBE::operator()(mod_t m=mtNONE, bool db = false)const
++double XPROBE::operator()(mod_t m, bool db)const
+ {
+ {if (OK()){
+ if (m == mtNONE) {