aboutsummaryrefslogtreecommitdiffstats
path: root/cad/gspiceui
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-01 21:18:21 +0800
committerbapt <bapt@FreeBSD.org>2012-06-01 21:18:21 +0800
commit4731dde58d46065936cb4e5d5cc90a1c28d51209 (patch)
tree7b84966f61227d2e957f51e93d2f7c00aadf0119 /cad/gspiceui
parent5288a5bc5ae68f669128326d195b9de6857de215 (diff)
downloadfreebsd-ports-gnome-4731dde58d46065936cb4e5d5cc90a1c28d51209.tar.gz
freebsd-ports-gnome-4731dde58d46065936cb4e5d5cc90a1c28d51209.tar.zst
freebsd-ports-gnome-4731dde58d46065936cb4e5d5cc90a1c28d51209.zip
Convert to new options framework
Diffstat (limited to 'cad/gspiceui')
-rw-r--r--cad/gspiceui/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/cad/gspiceui/Makefile b/cad/gspiceui/Makefile
index 87b940e4ffe1..1f02f5e27be3 100644
--- a/cad/gspiceui/Makefile
+++ b/cad/gspiceui/Makefile
@@ -20,8 +20,10 @@ LICENSE_FILE= ${WRKSRC}/License
RUN_DEPENDS= gwave:${PORTSDIR}/cad/gwave
-OPTIONS= NGSPICE "Use ng-spice as backend" on \
- GNUCAP "Use gnucap as backend" off
+OPTIONS_DEFINE= NGSPICE GNUCAP EXAMPLES DOCS
+OPTIONS_DEFAULT= NGSPICE
+NGSPICE_DESC= Use ng-spice as backend
+GNUCAP_DESC= Use gnucap as backend
USE_WX= 2.6+
WX_UNICODE= yes
@@ -34,13 +36,13 @@ PORTDOCS= *
PORTEXAMPLES= *
PLIST_FILES= bin/gspiceui
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NGSPICE)
+.if ${PORT_OPTIONS:MNGSPICE}
RUN_DEPENDS+= ngspice:${PORTSDIR}/cad/ngspice_rework
.endif
-.if defined(WITH_GNUCAP)
+.if ${PORT_OPTIONS:MGNUCAP}
RUN_DEPENDS+= gnucap:${PORTSDIR}/cad/gnucap
.endif
@@ -56,14 +58,14 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/gspiceui ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/gspiceui.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONs:MDOCS}
@${MKDIR} ${DOCSDIR}
.for dir in html
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${DOCSDIR} \
"! -name Makefile")
.endfor
.endif
-.if !defined(WITHOUT_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
.for dir in lib sch
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${EXAMPLESDIR} \
@@ -71,4 +73,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>