aboutsummaryrefslogtreecommitdiffstats
path: root/cad/kicad/Makefile
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-06-26 05:07:58 +0800
committertcberner <tcberner@FreeBSD.org>2017-06-26 05:07:58 +0800
commit19b60f6341c1340c532b32ab42000f8ef533e37c (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /cad/kicad/Makefile
parentcc28d78986356b14cfa92360db6e23f595431254 (diff)
downloadfreebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.tar.gz
freebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.tar.zst
freebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Diffstat (limited to 'cad/kicad/Makefile')
-rw-r--r--cad/kicad/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index ff0aca5f42d4..d06d1a29c293 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= xpdf:graphics/xpdf
CONFLICTS= kicad-devel*
-USES= cmake compiler:gcc-c++11-lib desktop-file-utils dos2unix \
+USES= cmake:noninja compiler:gcc-c++11-lib desktop-file-utils dos2unix \
shared-mime-info tar:xz
DOS2UNIX_GLOB= *.cmake sch_bus_entry.h sch_line.h sch_no_connect.h