aboutsummaryrefslogtreecommitdiffstats
path: root/cad/libgeda/Makefile
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-02-21 19:43:23 +0800
committerstas <stas@FreeBSD.org>2009-02-21 19:43:23 +0800
commitb54defd47141a3cb40a176c8f70e265b8ec93357 (patch)
treea8c53bf69bf28d09ddbfaa38f5021d23624ea02e /cad/libgeda/Makefile
parent3868a3c27c007f4867435814cbee297efc3cb196 (diff)
downloadfreebsd-ports-gnome-b54defd47141a3cb40a176c8f70e265b8ec93357.tar.gz
freebsd-ports-gnome-b54defd47141a3cb40a176c8f70e265b8ec93357.tar.zst
freebsd-ports-gnome-b54defd47141a3cb40a176c8f70e265b8ec93357.zip
- Bump PORTEPOCH, this was missed in previous update [1].
- Use proper shebang line in perl and python scripts [1]. - Define INSTALLS_ICONS and USE_GETTEXT where appropriate. - Implement WITHOUT_NLS knob. Reported by: Nick Withers <nick@nickwithers.com> [1]
Diffstat (limited to 'cad/libgeda/Makefile')
-rw-r--r--cad/libgeda/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/cad/libgeda/Makefile b/cad/libgeda/Makefile
index ad59ce51d350..4a85ef4e85b4 100644
--- a/cad/libgeda/Makefile
+++ b/cad/libgeda/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libgeda
PORTVERSION= 1.4.3
PORTREVISION= 0
+PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
http://geda.seul.org/release/v1.4/${PORTVERSION}/
@@ -27,6 +28,14 @@ CONFIGURE_ARGS= --disable-update-mime-database \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -E \
-e "s,^(DATADIR[[:space:]]*=[[:space:]]*)gEDA,\1geda," \