aboutsummaryrefslogtreecommitdiffstats
path: root/cad/mars/files
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>1997-04-26 05:54:51 +0800
committermax <max@FreeBSD.org>1997-04-26 05:54:51 +0800
commitce323d0ba3ac3c3c3919204c5fb5503d9bc997d4 (patch)
tree4c011540ce76f40b3d98aca27666c2a48e4d4a56 /cad/mars/files
parent8adee316b44f1812c41d40f4ab9533a57044a91f (diff)
downloadfreebsd-ports-gnome-ce323d0ba3ac3c3c3919204c5fb5503d9bc997d4.tar.gz
freebsd-ports-gnome-ce323d0ba3ac3c3c3919204c5fb5503d9bc997d4.tar.zst
freebsd-ports-gnome-ce323d0ba3ac3c3c3919204c5fb5503d9bc997d4.zip
Fix the problem that the build fails when `.' is not present in the $PATH.
PR: 3274 Submitted by: Matthew Hunt <mph@pobox.com>
Diffstat (limited to 'cad/mars/files')
-rw-r--r--cad/mars/files/patch-0318
1 files changed, 14 insertions, 4 deletions
diff --git a/cad/mars/files/patch-03 b/cad/mars/files/patch-03
index f4006ef022ad..a517b622560d 100644
--- a/cad/mars/files/patch-03
+++ b/cad/mars/files/patch-03
@@ -1,5 +1,14 @@
---- sim/Makefile.orig Tue Mar 15 16:37:49 1994
-+++ sim/Makefile Mon Nov 18 21:11:13 1996
+--- sim/Makefile.orig Wed Mar 16 09:37:49 1994
++++ sim/Makefile Sat Apr 26 06:21:50 1997
+@@ -19,7 +19,7 @@
+ ranlib $(MARSDIR)/lib/libMaRSSim.a
+
+ stat:
+- make_stat_headers $(CC) $(CC) $(CFLAGS) > ../include/stat.h
++ ./make_stat_headers $(CC) $(CC) $(CFLAGS) > ../include/stat.h
+ $(CC) $(CFLAGS) -c stat.c
+
+ lint:
@@ -40,114 +40,5 @@
# make dependencies
@@ -20,8 +29,7 @@
- echo '# DEPENDENCIES MUST END AT END OF FILE' >> Makefile
- echo '# IF YOU PUT STUFF HERE IT WILL GO AWAY' >> Makefile
- echo '# see make depend above' >> Makefile
-+ mkdep $(CFLAGS) ${SRCS}
-
+-
-# DO NOT DELETE THIS LINE
-main.o: ./include/component.h ./include/comptypes.h ./include/event.h
-main.o: ./include/eventdefs.h ./include/heap.h ./include/list.h ./include/log.h
@@ -116,3 +124,5 @@
-# DEPENDENCIES MUST END AT END OF FILE
-# IF YOU PUT STUFF HERE IT WILL GO AWAY
-# see make depend above
++ mkdep $(CFLAGS) ${SRCS}
++