aboutsummaryrefslogtreecommitdiffstats
path: root/cad/opencascade
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2007-04-22 04:23:58 +0800
committerthierry <thierry@FreeBSD.org>2007-04-22 04:23:58 +0800
commit08d14aa3b7a8785e2ba9bf9aa2e068d74363a8ec (patch)
tree93c5b8b43f67aa93b5a0cc3dac9ef1a464c5f29a /cad/opencascade
parent436d233a20e4b59fcc1e457bda326379a8978bc1 (diff)
downloadfreebsd-ports-gnome-08d14aa3b7a8785e2ba9bf9aa2e068d74363a8ec.tar.gz
freebsd-ports-gnome-08d14aa3b7a8785e2ba9bf9aa2e068d74363a8ec.tar.zst
freebsd-ports-gnome-08d14aa3b7a8785e2ba9bf9aa2e068d74363a8ec.zip
Add a work-around to fix build with gcc 4.1 on pointyhat.
Reported by: pointyhat via Kris Obtained from: Open Cascade
Diffstat (limited to 'cad/opencascade')
-rw-r--r--cad/opencascade/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index d1465d7b07cf..cf0dbfc32aa9 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -63,7 +63,7 @@ CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
--with-stlport-libname=stlport_${STL_COMPILER} \
--with-stlport-library=${LOCALBASE}/lib \
--enable-production=yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${X11BASE}/include \
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} ${GCC4WA} -I${X11BASE}/include \
-I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}" ARCH=${ARCH}
# We strip the libs
MAKE_ENV= INSTALL_STRIP_FLAG=-s OCC_BUILDDIR="${PATCH_WRKSRC}" \
@@ -95,6 +95,11 @@ DIR2INST+= doc
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 700036 && defined(PACKAGE_BUILDING)
+# Work-around for gcc-41+
+GCC4WA= -ffriend-injection -fpermissive
+.endif
+
.if defined(MAINTAINER_MODE) # Get the sources & roll the tarballs
PRIM_MASTER_SITES= http://files.opencascade.com/OCC_${PORTVERSION}_release/