aboutsummaryrefslogtreecommitdiffstats
path: root/cad/openscad
diff options
context:
space:
mode:
authormr <mr@FreeBSD.org>2011-08-19 19:02:10 +0800
committermr <mr@FreeBSD.org>2011-08-19 19:02:10 +0800
commit35dda36c5a76f29e6f8b90755575f84b1d5e41a9 (patch)
treed69faa8ae3305ee5cb37fb9fee1f3bb65000e6df /cad/openscad
parent0c3cafedc36cbbe4b3c23b4ec40a710de56b96b5 (diff)
downloadfreebsd-ports-gnome-35dda36c5a76f29e6f8b90755575f84b1d5e41a9.tar.gz
freebsd-ports-gnome-35dda36c5a76f29e6f8b90755575f84b1d5e41a9.tar.zst
freebsd-ports-gnome-35dda36c5a76f29e6f8b90755575f84b1d5e41a9.zip
Add openscad.
OpenSCAD is a software for creating 3D CAD objects. Unlike most free software for creating 3D models, it does not focus on the artistic aspects of 3D modelling but instead on the CAD aspects. Thus it is more suitable for creating 3D models of machine parts but perhaps not when creating computer-animated movies. OpenSCAD is not an interactive modeller. Instead it is something like a 3D-compiler that reads in a script file that describes the object and renders the 3D model from this script file. This gives designers full control over the modelling process and enables them to easily change any step in the modelling process or make designes that are defined by configurable parameters. WWW: http://www.openscad.org/ Obtained from (slightly): OpenBSD
Diffstat (limited to 'cad/openscad')
-rw-r--r--cad/openscad/Makefile49
-rw-r--r--cad/openscad/distinfo2
-rw-r--r--cad/openscad/files/patch-aa10
-rw-r--r--cad/openscad/pkg-descr15
-rw-r--r--cad/openscad/pkg-plist35
5 files changed, 111 insertions, 0 deletions
diff --git a/cad/openscad/Makefile b/cad/openscad/Makefile
new file mode 100644
index 000000000000..ecf36afe2311
--- /dev/null
+++ b/cad/openscad/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: openscad
+# Date created: 17 August 2011
+# Whom: Michael Reifenberger <mr@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openscad
+PORTVERSION= 2011.06
+#PORTREVISION= 0
+CATEGORIES= cad
+MASTER_SITES= https://cloud.github.com/downloads/openscad/openscad/
+DISTNAME= openscad-${PORTVERSION}.src
+
+MAINTAINER= mr@FreeBSD.org
+COMMENT= The programmer's solid 3D CAD modeller
+
+BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
+ flex:${PORTSDIR}/textproc/flex \
+ eigen>=2.0.3:${PORTSDIR}/math/eigen2 \
+ ${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boost-libs
+#RUN_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= GLU.1:${PORTSDIR}/graphics/libGLU \
+ gmp.10:${PORTSDIR}/math/gmp \
+ mpfr.4:${PORTSDIR}/math/mpfr \
+ CGAL.5:${PORTSDIR}/math/cgal \
+ opencsg:${PORTSDIR}/graphics/opencsg
+
+USE_GL= glew
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+#MAKE_JOBS_UNSAFE=yes
+QMAKE_ENV = EIGEN2DIR=${LOCALBASE}/include/eigen2
+QMAKE_FLAGS = VERSION=${PORTVERSION}
+MAKE_ENV = INSTALL_ROOT=${DESTDIR}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's,XXXFLEXXX,"${LOCALBASE}/bin/flex",' \
+ ${WRKSRC}/openscad.pro
+ ${REINPLACE_CMD} -e 's,XXXBISONXXX,"${LOCALBASE}/bin/bison",' \
+ ${WRKSRC}/openscad.pro
+
+do-configure:
+ cd ${WRKSRC} && \
+ ${SETENV} ${QMAKE_ENV} ${QMAKE} ${QMAKE_FLAGS} openscad.pro
+
+.include <bsd.port.mk>
diff --git a/cad/openscad/distinfo b/cad/openscad/distinfo
new file mode 100644
index 000000000000..d50a4430afc2
--- /dev/null
+++ b/cad/openscad/distinfo
@@ -0,0 +1,2 @@
+SHA256 (openscad-2011.06.src.tar.gz) = 693c0ca033639c52c3d2d11f4d537963dc3a3bc0d2e3a2e63da460f6898c30db
+SIZE (openscad-2011.06.src.tar.gz) = 920506
diff --git a/cad/openscad/files/patch-aa b/cad/openscad/files/patch-aa
new file mode 100644
index 000000000000..455d3f2923ab
--- /dev/null
+++ b/cad/openscad/files/patch-aa
@@ -0,0 +1,10 @@
+--- openscad.pro.orig 2011-08-19 12:29:45.662036017 +0200
++++ openscad.pro 2011-08-19 12:31:55.374020178 +0200
+@@ -15,4 +15,7 @@
+ }
+
++QMAKE_LEX = XXXFLEXXX
++QMAKE_YACC = XXXBISONXXX
++
+ #configure lex / yacc
+ win32 {
diff --git a/cad/openscad/pkg-descr b/cad/openscad/pkg-descr
new file mode 100644
index 000000000000..c1c1110ddafa
--- /dev/null
+++ b/cad/openscad/pkg-descr
@@ -0,0 +1,15 @@
+OpenSCAD is a software for creating 3D CAD objects.
+
+Unlike most free software for creating 3D models, it does not focus on
+the artistic aspects of 3D modelling but instead on the CAD aspects.
+Thus it is more suitable for creating 3D models of machine parts but
+perhaps not when creating computer-animated movies.
+
+OpenSCAD is not an interactive modeller. Instead it is something like
+a 3D-compiler that reads in a script file that describes the object
+and renders the 3D model from this script file. This gives designers
+full control over the modelling process and enables them to easily
+change any step in the modelling process or make designes that are
+defined by configurable parameters.
+
+WWW: http://www.openscad.org/
diff --git a/cad/openscad/pkg-plist b/cad/openscad/pkg-plist
new file mode 100644
index 000000000000..bc45cb3b2289
--- /dev/null
+++ b/cad/openscad/pkg-plist
@@ -0,0 +1,35 @@
+bin/openscad
+%%DATADIR%%/examples/example001.scad
+%%DATADIR%%/examples/example002.scad
+%%DATADIR%%/examples/example003.scad
+%%DATADIR%%/examples/example004.scad
+%%DATADIR%%/examples/example005.scad
+%%DATADIR%%/examples/example006.scad
+%%DATADIR%%/examples/example007.dxf
+%%DATADIR%%/examples/example007.scad
+%%DATADIR%%/examples/example008.dxf
+%%DATADIR%%/examples/example008.scad
+%%DATADIR%%/examples/example009.dxf
+%%DATADIR%%/examples/example009.scad
+%%DATADIR%%/examples/example010.dat
+%%DATADIR%%/examples/example010.scad
+%%DATADIR%%/examples/example011.scad
+%%DATADIR%%/examples/example012.scad
+%%DATADIR%%/examples/example012.stl
+%%DATADIR%%/examples/example013.dxf
+%%DATADIR%%/examples/example013.scad
+%%DATADIR%%/examples/example014.scad
+%%DATADIR%%/examples/example015.scad
+%%DATADIR%%/examples/example016.scad
+%%DATADIR%%/examples/example016.stl
+%%DATADIR%%/examples/example017.scad
+%%DATADIR%%/examples/example018.scad
+%%DATADIR%%/examples/example019.scad
+%%DATADIR%%/examples/example020.scad
+%%DATADIR%%/examples/example021.scad
+%%DATADIR%%/examples/example022.scad
+%%DATADIR%%/libraries/boxes.scad
+%%DATADIR%%/libraries/shapes.scad
+@dirrm %%DATADIR%%/libraries
+@dirrm %%DATADIR%%/examples
+@dirrm %%DATADIR%%