aboutsummaryrefslogtreecommitdiffstats
path: root/cad/pcb/Makefile
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2010-10-01 03:02:31 +0800
committerhrs <hrs@FreeBSD.org>2010-10-01 03:02:31 +0800
commitb08d68ede04d977cdda935452d8e367d2ac0179e (patch)
tree802c98910be93af1e81dcffa765b17e3409c577e /cad/pcb/Makefile
parent0a0d2f58827bdd319f9e3e11ba95c3de8fc41e95 (diff)
downloadfreebsd-ports-gnome-b08d68ede04d977cdda935452d8e367d2ac0179e.tar.gz
freebsd-ports-gnome-b08d68ede04d977cdda935452d8e367d2ac0179e.tar.zst
freebsd-ports-gnome-b08d68ede04d977cdda935452d8e367d2ac0179e.zip
Update to 20100929. Changes include:
Features -------- - PCB can directly import (forward annotate) schematics while running. - Many places where measurements are entered now accept units, like "5mm", and "cm" and "in" are allowed too. - Free Rotate Buffer added to menu - Polygon Hole tool. - F12 invokes the Lock tool. - Russian translation added. - DBUS is enabled by default when possible. - Command-line exporters can run action scripts too. - GTK tool tips on elements, pins, and nets. - Command-line actions in GUIs do not require (,,) syntax. - PCB can import footprints both in subdirectories and the named directories. - New GCode exporter. - Footprint files use ".fp" as the suffix; this is automatically searched for if needed. - GTK dialogs do not show at startup unless requested. - Stackup can be specified on the command line for command-line exporting. - Reference card updated. - The snap-point in pads is the center. - The 's' key toggles polygons to clear/notclear all pads and pins Bug Fixes --------- - Various PNG export fixes. - lesstif's magic toggle-layers-on-flip fixed. - Arc bounding box math fixed. - Fixed: sometimes, disabling silk also disabled the solder layer. - "pcb --help" prints all options again - Add mnemonic for "close without saving" - Don't select silk on the back side when it's invisible. - Various polygon rendering bugs fixed. - PNG drill bloat export fixed. - Attempts to change polygon clearance *on* polygons results in a hint. - PNG doesn't segfault if not all graphic formats are supported. - Various toporouter fixes and improvements - HID_Mixed is supported in attribute dialogs - Flipped rectangles in PS exports are drawn correctly. - Optimizer removes micro-traces under pads. - Vias, pins, and pads are now drawn under the mask instead of over.
Diffstat (limited to 'cad/pcb/Makefile')
-rw-r--r--cad/pcb/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/cad/pcb/Makefile b/cad/pcb/Makefile
index 25c7798ef7d2..8c804d02cad8 100644
--- a/cad/pcb/Makefile
+++ b/cad/pcb/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pcb
-PORTVERSION= 20091103
+PORTVERSION= 20100929
CATEGORIES= cad
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -26,7 +26,8 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
INSTALL_DATA="/usr/bin/install ${COPY} ${_SHROWNGRP} -m ${SHAREMODE}"
CONFIGURE_ARGS= --docdir=${DOCSDIR} --disable-nls
PORTDOCS= pcb.html pcb.ps refcard.ps pcb.pdf refcard.pdf pad.gif \
- puller.gif thermal.gif pad.png puller.png thermal.png
+ puller.gif thermal.gif pad.png puller.png thermal.png examples \
+ tutorial
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --without-gui