aboutsummaryrefslogtreecommitdiffstats
path: root/cad/pdnmesh/Makefile
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-04-19 15:01:00 +0800
committervs <vs@FreeBSD.org>2004-04-19 15:01:00 +0800
commit7fd6448d305ac70d9f98cb9ce06c632180e25743 (patch)
tree2837b1ebf36b3d5289c5059c117c5c516a3fcdc2 /cad/pdnmesh/Makefile
parentb3e570e77a9ff341424c4971cf19347eaed7c1d7 (diff)
downloadfreebsd-ports-gnome-7fd6448d305ac70d9f98cb9ce06c632180e25743.tar.gz
freebsd-ports-gnome-7fd6448d305ac70d9f98cb9ce06c632180e25743.tar.zst
freebsd-ports-gnome-7fd6448d305ac70d9f98cb9ce06c632180e25743.zip
Unbreak if Mesa/libglut not present.
Submitted by: maintainer Approved by: linimon (mentor)
Diffstat (limited to 'cad/pdnmesh/Makefile')
-rw-r--r--cad/pdnmesh/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/cad/pdnmesh/Makefile b/cad/pdnmesh/Makefile
index 31b3d91c1b5c..e4667708826a 100644
--- a/cad/pdnmesh/Makefile
+++ b/cad/pdnmesh/Makefile
@@ -17,6 +17,7 @@ COMMENT= A finite element program
LIB_DEPENDS= gtkglext:${PORTSDIR}/x11-toolkits/gtkglext:install
+USE_REINPLACE= yes
USE_XLIB= yes
USE_GL= yes
GNU_CONFIGURE= yes
@@ -25,4 +26,9 @@ CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
MAN1= pdnmesh.1
MAN5= pdnmesh_input.5
+post-patch:
+.for FILE in ${DISTNAME}/src/contour.c
+ @${REINPLACE_CMD} -e "s/^\#include <GL\/glut.h>//g" ${WRKSRC}/${FILE}
+.endfor
+
.include <bsd.port.mk>