aboutsummaryrefslogtreecommitdiffstats
path: root/cad/pisces/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-11-09 06:55:29 +0800
committersteve <steve@FreeBSD.org>2000-11-09 06:55:29 +0800
commitbd123f24cedc50b153dc861bfb92339d612652a6 (patch)
treed0585f63374dfb89902ae03359e5f0b0209c9d41 /cad/pisces/Makefile
parent3ff11d346d75a0eddca25e3111cc94cfbddedb86 (diff)
downloadfreebsd-ports-gnome-bd123f24cedc50b153dc861bfb92339d612652a6.tar.gz
freebsd-ports-gnome-bd123f24cedc50b153dc861bfb92339d612652a6.tar.zst
freebsd-ports-gnome-bd123f24cedc50b153dc861bfb92339d612652a6.zip
Better handling for the imake dependency when XFREE86_VERSION != 3. The
old way had us installing imake-4 over the imake that is already a part of the XFree86-3 port.
Diffstat (limited to 'cad/pisces/Makefile')
-rw-r--r--cad/pisces/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/cad/pisces/Makefile b/cad/pisces/Makefile
index b326ab38eae2..32a49d658334 100644
--- a/cad/pisces/Makefile
+++ b/cad/pisces/Makefile
@@ -14,8 +14,13 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= masini@uniroma3.it
-BUILD_DEPENDS= f2c:${PORTSDIR}/lang/f2c \
- imake:${PORTSDIR}/devel/imake-4
+BUILD_DEPENDS= f2c:${PORTSDIR}/lang/f2c
+
+.include <bsd.port.pre.mk>
+
+.if ${XFREE86_VERSION} != 3
+BUILD_DEPENDS+= imake:${PORTSDIR}/devel/imake-4
+.endif
NO_WRKSUBDIR= yes
USE_XLIB= yes
@@ -38,4 +43,4 @@ post-install:
${CP} -R ${WRKSRC}/pisces/9009/test_suite ${PREFIX}/share/doc/pisces
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>