aboutsummaryrefslogtreecommitdiffstats
path: root/cad/qcad-partslib/Makefile
diff options
context:
space:
mode:
authormr <mr@FreeBSD.org>2005-11-27 17:37:58 +0800
committermr <mr@FreeBSD.org>2005-11-27 17:37:58 +0800
commite805becbbd07211da9f02177c607190992679741 (patch)
tree5aa572f5b0f3daa7f8d1f8823679d856e68b6571 /cad/qcad-partslib/Makefile
parent930f4c98336a3d1df7d2abeb4e0655072faec7bb (diff)
downloadfreebsd-ports-gnome-e805becbbd07211da9f02177c607190992679741.tar.gz
freebsd-ports-gnome-e805becbbd07211da9f02177c607190992679741.tar.zst
freebsd-ports-gnome-e805becbbd07211da9f02177c607190992679741.zip
fix pkg-plist
Diffstat (limited to 'cad/qcad-partslib/Makefile')
-rw-r--r--cad/qcad-partslib/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/cad/qcad-partslib/Makefile b/cad/qcad-partslib/Makefile
index c17ef95e676b..52cf4b6ffec3 100644
--- a/cad/qcad-partslib/Makefile
+++ b/cad/qcad-partslib/Makefile
@@ -28,12 +28,14 @@ PLIST= ${WRKDIR}/pkg-plist
.include <bsd.port.pre.mk>
pre-install:
+ @${ECHO_CMD} '@exec mkdir -p %D/share/qcad/libraries' > ${PLIST}
@${FIND} ${WRKSRC} -type f | \
- ${SED} -e "s:^${WRKSRC}/:share/qcad/library/:g" > ${PLIST}
- @${FIND} -d ${WRKSRC}/* -type d | \
+ ${SED} -e "s:^${WRKSRC}/:share/qcad/library/:g" >> ${PLIST}
+ @${FIND} -d ${WRKSRC} -type d | \
${SED} -e "s:^${WRKSRC}:@dirrm share/qcad/library:g" >> ${PLIST}
do-install:
+ @${MKDIR} ${DATADIR}
${TAR} -C ${WRKSRC} --exclude CVS -cf - . | \
${TAR} -C ${DATADIR} --unlink -xf -