aboutsummaryrefslogtreecommitdiffstats
path: root/cad/qcad
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2001-03-11 13:01:04 +0800
committersteve <steve@FreeBSD.org>2001-03-11 13:01:04 +0800
commitb6679516f174616a60f3cfbe7498793c18658a65 (patch)
treecf9ac5c315197e72e665895d86207c2c5a1b87d6 /cad/qcad
parent57156ba907e0997b744cb722c78a0aa0f5cab004 (diff)
downloadfreebsd-ports-gnome-b6679516f174616a60f3cfbe7498793c18658a65.tar.gz
freebsd-ports-gnome-b6679516f174616a60f3cfbe7498793c18658a65.tar.zst
freebsd-ports-gnome-b6679516f174616a60f3cfbe7498793c18658a65.zip
Use '-O0' when compiling on the Alpha to avoid internal compiler errors.
Diffstat (limited to 'cad/qcad')
-rw-r--r--cad/qcad/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/cad/qcad/Makefile b/cad/qcad/Makefile
index 8f5e50f9ae83..7d2da0e654c9 100644
--- a/cad/qcad/Makefile
+++ b/cad/qcad/Makefile
@@ -17,6 +17,12 @@ USE_XLIB= yes
USE_QT2= yes
MAKE_ENV= QTDIR="${X11BASE}"
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS+= -O0
+.endif
+
post-patch:
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/*.cpp
@@ -37,4 +43,4 @@ do-install:
@${LN} -sf ${PREFIX}/share/doc/qcad ${PREFIX}/share/qcad/doc
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>