aboutsummaryrefslogtreecommitdiffstats
path: root/cad/qelectrotech/Makefile
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2010-07-21 17:57:57 +0800
committerashish <ashish@FreeBSD.org>2010-07-21 17:57:57 +0800
commit9f4b4531eaf0472de68150c0f80af79e69e32980 (patch)
treeebf9c4000ab30f8fb02d339d81a01639ffaccb99 /cad/qelectrotech/Makefile
parentf88c57a0a803be22781053bec3891b672cf5db27 (diff)
downloadfreebsd-ports-gnome-9f4b4531eaf0472de68150c0f80af79e69e32980.tar.gz
freebsd-ports-gnome-9f4b4531eaf0472de68150c0f80af79e69e32980.tar.zst
freebsd-ports-gnome-9f4b4531eaf0472de68150c0f80af79e69e32980.zip
QElectroTech is a Qt4 application to design electric diagrams. It uses XML
files for elements and diagrams, and includes both a diagram editor and an element editor. WWW: http://qelectrotech.org/ PR: ports/146513 Submitted by: Gvozdikov Veniamin <g.veniamin at googlemail.com> Approved by: pgj (mentor)
Diffstat (limited to 'cad/qelectrotech/Makefile')
-rw-r--r--cad/qelectrotech/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/cad/qelectrotech/Makefile b/cad/qelectrotech/Makefile
new file mode 100644
index 000000000000..a19467252189
--- /dev/null
+++ b/cad/qelectrotech/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: qelectrotech
+# Date created: 2010-03-24
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qelectrotech
+PORTVERSION= 0.22
+CATEGORIES= cad
+MASTER_SITES= http://download.tuxfamily.org/qet/tags/20100313/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= QElectroTech is application to design electric diagrams
+
+USE_QT_VER= 4
+QT_COMPONENTS= gui network svg xml \
+ moc_build qmake_build rcc_build uic_build
+INSTALLS_ICONS= yes
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+MAN1= qelectrotech.1
+MANLANG= "" es fr.ISO8859-1 fr.UTF-8 fr pt_PT
+MANCOMPRESSED= yes
+
+post-extract:
+ @${CP} ${WRKSRC}/LICENSE ${WRKSRC}/COPYING
+
+do-configure:
+ ${MV} ${WRKSRC}/man/files/pt ${WRKSRC}/man/files/pt_PT
+ ${REINPLACE_CMD} -e 's,/usr/local/,${PREFIX}/,g' \
+ ${WRKSRC}/${PORTNAME}.pro
+ ${REINPLACE_CMD} -e 's,doc/,share/doc/,g' \
+ ${WRKSRC}/${PORTNAME}.pro
+ ${REINPLACE_CMD} -e 's,../share,share,g' \
+ ${WRKSRC}/${PORTNAME}.pro
+ cd ${WRKSRC} && ${QMAKE} ${PORTNAME}.pro
+
+.include <bsd.port.mk>