aboutsummaryrefslogtreecommitdiffstats
path: root/cad/spice/Makefile
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2003-07-19 11:13:48 +0800
committermaho <maho@FreeBSD.org>2003-07-19 11:13:48 +0800
commitdc2677ab3333caedb1297926170c3d727f46e9d5 (patch)
tree2073426ac7c87dcdb0f427915333b88baf51a2c8 /cad/spice/Makefile
parent3ae4198324d799f6bfcd01d7af33786d0c26b71d (diff)
downloadfreebsd-ports-gnome-dc2677ab3333caedb1297926170c3d727f46e9d5.tar.gz
freebsd-ports-gnome-dc2677ab3333caedb1297926170c3d727f46e9d5.tar.zst
freebsd-ports-gnome-dc2677ab3333caedb1297926170c3d727f46e9d5.zip
1. REAL cleaning on this port. The files dir is now organized so the
port can be maintained: previously there were multifile patches and several patches for the same file, now it is a lot cleaner. 2. I also merged a memory leak fix and some fixes from spice3f5-spaghetti. 4. MFB and removed GNUREADLINE support 5. honor CFLAGS and CC. 6. Add documentation. 7. Maho didn't change the name of port spice to spice3. because spice4 might :) appear in the future. version number should be listed on *only* PORTVERSION. 8. drom maintainership PR: 54603 Submitted by: "Pedro F. Giffuni" <giffunip@yahoo.com>
Diffstat (limited to 'cad/spice/Makefile')
-rw-r--r--cad/spice/Makefile25
1 files changed, 18 insertions, 7 deletions
diff --git a/cad/spice/Makefile b/cad/spice/Makefile
index c584172e2bb3..7c4d14f30323 100644
--- a/cad/spice/Makefile
+++ b/cad/spice/Makefile
@@ -8,26 +8,37 @@
PORTNAME= spice
PORTVERSION= 3f5.2
CATEGORIES= cad
-MASTER_SITES= ftp://ic.eecs.berkeley.edu/pub/Spice3/
-DISTNAME= sp3f4.kit
+MASTER_SITES= ftp://ic.eecs.berkeley.edu/pub/Spice3/:sources \
+ ftp://ic.eecs.berkeley.edu/pub/Spice3/um.3f3.ps/:docs
EXTRACT_SUFX= .tar.Z
+DISTFILES= sp3f4.kit${EXTRACT_SUFX}:sources \
+ cp.ps:docs toc.ps:docs doc.ps:docs
+DIST_SUBDIR= spice
+EXTRACT_ONLY= sp3f4.kit${EXTRACT_SUFX}
-MAINTAINER= maho@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A general-purpose circuit simulation program
-# documentation in ftp://ic.eecs.berkeley.edu/pub/Spice3/um.3f3.ps/
-
USE_XLIB= yes
+USE_REINPLACE= yes
NO_WRKSUBDIR= yes
MAN1= sconvert.1 nutmeg.1 spice.1
MAN3= mfb.3
MAN5= mfbcap.5
MLINKS= spice.1 spice3.1
+post-configure:
+ @${REINPLACE_CMD} -e 's+@CC@+${CC}+ ; s+@CFLAGS@+${CFLAGS}+ ; \
+ s+@X11BASE@+${X11BASE}+;' \
+ ${WRKSRC}/conf/FreeBSD
+
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/examples/spice3
- ${INSTALL_DATA} ${WRKSRC}/examples/*.cir ${PREFIX}/share/examples/spice3
+ ${MKDIR} ${DOCSDIR}
+ ${CAT} ${DISTDIR}/${DIST_SUBDIR}/*.ps > ${DOCSDIR}/spice3f3.ps
+ ${GZIP_CMD} ${DOCSDIR}/*.ps
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.cir ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>