aboutsummaryrefslogtreecommitdiffstats
path: root/cad/spice/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1996-05-23 16:17:41 +0800
committertg <tg@FreeBSD.org>1996-05-23 16:17:41 +0800
commit449cd2a9e7e55957a81f54deffc7f01265cf00b5 (patch)
tree106441d5075c7a631a4ab4dbc0e4119e1618d997 /cad/spice/Makefile
parent0f3e0e55dfbf8e03db468209a2b2ede241b6da97 (diff)
downloadfreebsd-ports-gnome-449cd2a9e7e55957a81f54deffc7f01265cf00b5.tar.gz
freebsd-ports-gnome-449cd2a9e7e55957a81f54deffc7f01265cf00b5.tar.zst
freebsd-ports-gnome-449cd2a9e7e55957a81f54deffc7f01265cf00b5.zip
Finally, a port of the famous circuit simulation system.
Submitted by: Julian Jenkins <kaveman@magna.com.au>
Diffstat (limited to 'cad/spice/Makefile')
-rw-r--r--cad/spice/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/cad/spice/Makefile b/cad/spice/Makefile
new file mode 100644
index 000000000000..8c4bced071d1
--- /dev/null
+++ b/cad/spice/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: spice
+# Version required: 3f4 (3f5?)
+# Date created: 26 Mar 96
+# Whom: Julian Jenkins <kaveman@magna.com.au>
+#
+#
+
+DISTNAME= spice3f4
+PKGNAME= spice-3f4
+CATEGORIES+= cad
+MASTER_SITES= ftp://sunsite.unc.edu/pub/Linux/apps/circuits/
+
+#PATCH_SITES= ftp://ic.eecs.berkeley.edu/pub/Spice3/3f4patches
+#PATCHFILES= grid.patch newcoms.patch spsmp.patch
+# documentation in ftp://ic.eecs.berkeley.edu/pub/Spice3/um.3f3.ps
+
+MAINTAINER= kaveman@magna.com.au
+
+# export restrictions
+NO_CDROM= yes
+
+post-install:
+ chmod a+rx ${PREFIX}/bin/spice3 ${PREFIX}/bin/nutmeg \
+ ${PREFIX}/bin/sconvert ${PREFIX}/bin/help ${PREFIX}/bin/proc2mod \
+ ${PREFIX}/bin/multidec
+ strip ${PREFIX}/bin/spice3 ${PREFIX}/bin/nutmeg \
+ ${PREFIX}/bin/sconvert ${PREFIX}/bin/help ${PREFIX}/bin/proc2mod \
+ ${PREFIX}/bin/multidec
+ chmod -R a+rX ${PREFIX}/share/spice
+ chmod a+rx ${PREFIX}/man/man5/mfbcap.5.gz \
+ ${PREFIX}/man/man1/sconvert.1.gz ${PREFIX}/man/man1/nutmeg.1.gz \
+ ${PREFIX}/man/man1/spice.1.gz ${PREFIX}/man/man3/mfb.3.gz
+
+.include <bsd.port.mk>