aboutsummaryrefslogtreecommitdiffstats
path: root/cad/spice
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2015-02-15 21:33:38 +0800
committerhrs <hrs@FreeBSD.org>2015-02-15 21:33:38 +0800
commitfc68c91fe2fe9c7f728ae0cc6d04cd5f9722ad23 (patch)
tree33d1a6852d93baaeaa3977acaae0022d7151341b /cad/spice
parentd09ce0f63f676bc2b7008172c790e53fe600b6e8 (diff)
downloadfreebsd-ports-gnome-fc68c91fe2fe9c7f728ae0cc6d04cd5f9722ad23.tar.gz
freebsd-ports-gnome-fc68c91fe2fe9c7f728ae0cc6d04cd5f9722ad23.tar.zst
freebsd-ports-gnome-fc68c91fe2fe9c7f728ae0cc6d04cd5f9722ad23.zip
- Fix device support. The previous version was totally broken.
- Fix help(1).
Diffstat (limited to 'cad/spice')
-rw-r--r--cad/spice/Makefile7
-rw-r--r--cad/spice/files/Makefile9
-rw-r--r--cad/spice/pkg-plist2
3 files changed, 14 insertions, 4 deletions
diff --git a/cad/spice/Makefile b/cad/spice/Makefile
index 201f9aad3fe3..5a84e680d03c 100644
--- a/cad/spice/Makefile
+++ b/cad/spice/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spice
PORTVERSION= 3f5.2
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= cad
MASTER_SITES= http://embedded.eecs.berkeley.edu/pubs/downloads/spice/:srcs \
http://www-device.eecs.berkeley.edu/~bsim/Files/BSIM3/ftpv330/src/:bsim3 \
@@ -102,9 +102,12 @@ post-extract:
${CONFIGFILE}::
@${SETENV} ${CONFIGURE_ENV} ${MAKE} -f ${MAKEFILE} configure
-.for V in CC MAKE CC_OPT DEVICES
+.for V in CC MAKE CC_OPT
@${ECHO_CMD} "${V}=${$V}" >> ${WRKSRC}/conf/FreeBSD
.endfor
+.for V in DEVICES
+ @${ECHO_CMD} "${V}+=${$V}" >> ${WRKSRC}/conf/FreeBSD
+.endfor
do-configure: ${CONFIGFILE}
@${DO_NADA}
diff --git a/cad/spice/files/Makefile b/cad/spice/files/Makefile
index 085bfcc1cd53..26f197d0c0ac 100644
--- a/cad/spice/files/Makefile
+++ b/cad/spice/files/Makefile
@@ -32,8 +32,8 @@ SHAREFILESDIR= ${PREFIX}/share/spice
HELPFILESDIR= ${SHAREFILESDIR}/helpdir
SCRIPTFILESDIR= ${SHAREFILESDIR}/scripts
-PROGRAMS= spice3 nutmeg sconvert help proc2mod multidec
-HELPFILES= spice.txt
+PROGRAMS= spice3 nutmeg sconvert help proc2mod multidec makeidx
+HELPFILES= spice.txt spice.idx
SCRIPTFILES= setplot spinit
SHAREFILES= mfbcap news
@@ -54,6 +54,11 @@ ${DESTDIR}${MANDIR}${n}/$M: $M
.endfor
ln -s -f spice.1 ${DESTDIR}${MANDIR}1/spice3.1
+spice.idx: spice.txt
+ ${DESTDIR}${BINDIR}/makeidx ${.ALLSRC}
+ ${BSD_INSTALL_DATA} ${.CURDIR}/lib/helpdir/spice.idx \
+ ${.CURDIR}/spice.idx
+
.for D in HELPFILES SCRIPTFILES SHAREFILES
. for F in ${${D}}
install:: ${DESTDIR}${${D}DIR}/$F
diff --git a/cad/spice/pkg-plist b/cad/spice/pkg-plist
index d91dc3b2f305..a2e9bf17b910 100644
--- a/cad/spice/pkg-plist
+++ b/cad/spice/pkg-plist
@@ -4,6 +4,7 @@ bin/sconvert
bin/help
bin/proc2mod
bin/multidec
+bin/makeidx
man/man1/sconvert.1.gz
man/man1/nutmeg.1.gz
man/man1/spice.1.gz
@@ -11,6 +12,7 @@ man/man1/spice3.1.gz
man/man3/mfb.3.gz
man/man5/mfbcap.5.gz
%%DATADIR%%/helpdir/spice.txt
+%%DATADIR%%/helpdir/spice.idx
%%DATADIR%%/scripts/setplot
%%DATADIR%%/scripts/spinit
%%DATADIR%%/mfbcap