aboutsummaryrefslogtreecommitdiffstats
path: root/cad/tclspice/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-06-27 02:34:59 +0800
committerpav <pav@FreeBSD.org>2006-06-27 02:34:59 +0800
commitd5800da692242fd547b3d7b88d348a35751fdaf2 (patch)
treed4119bb02dd9c4b2b1a9711b3ca2636c68d552c3 /cad/tclspice/Makefile
parent0b8b3fa270816dc38b170e98c37d591ea3c70bbd (diff)
downloadfreebsd-ports-gnome-d5800da692242fd547b3d7b88d348a35751fdaf2.tar.gz
freebsd-ports-gnome-d5800da692242fd547b3d7b88d348a35751fdaf2.tar.zst
freebsd-ports-gnome-d5800da692242fd547b3d7b88d348a35751fdaf2.zip
TclSpice is an improved version of Berkeley Spice designed to be used with
the Tcl/Tk scripting language. The project is open-source (BSD license) and based upon the NG-Spice source code base with many improvements Features and Improvements - Fully Tcl scriptable - installs with 'package require spice' statement - Hspice syntax (SpicePP). - GUI interfaces, various (Tk). - SpiceWish (BLT graph widget) - BLT (tcl compatible) vectors for storage, manipulation and arithmetic upon Spice waveforms. - Xspice additions (Georgia Tech). - Trigger upon waveform events. - Spice 'simulator state' save and restore for rapid 'what-if' simulations (no longer need to re-simulate from the beginning each time a device value is changed). Author: Stefan Jones <stefan.jones@multigig.com> WWW: http://tclspice.sourceforge.net/ PR: ports/99399 Submitted by: Stanislav Sedov <ssedov@mbsd.msk.ru>
Diffstat (limited to 'cad/tclspice/Makefile')
-rw-r--r--cad/tclspice/Makefile67
1 files changed, 67 insertions, 0 deletions
diff --git a/cad/tclspice/Makefile b/cad/tclspice/Makefile
new file mode 100644
index 000000000000..d9f9f543e905
--- /dev/null
+++ b/cad/tclspice/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: tclspice
+# Date created: 2006-06-24
+# Whom: Stanislav Sedov <stas@fonon.realnet>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tclspice
+PORTVERSION= 0.2.18
+CATEGORIES= cad
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tclspice
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Improved version on SPICE3 suite with TCL scripting features
+
+BUILD_DEPENDS= bltwish:${PORTSDIR}/x11-toolkits/blt \
+ ${LOCALBASE}/lib/libtclreadline.so:${PORTSDIR}/devel/tclreadline
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_AUTOTOOLS= aclocal:19 automake:19 autoconf:259 libtool:15
+AUTOMAKE_ARGS= -c -a
+USE_GMAKE= yes
+ALL_TARGET= tcl
+INSTALL_TARGET= install-tcl
+INSTALLS_SHLIB= yes
+
+SUB_FILES= pkg-message
+
+OPTIONS= EXPERIMENTAL "Enable experimental features" on \
+ EXAMPLES "Install sample scrips" on
+
+CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.4
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include ${CFLAGS} -fPIC" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
+
+WISH= ${LOCALBASE}/bin/wish8.4
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_EXPERIMENTAL)
+CONFIGURE_ARGS+= --enable-experimental
+.endif
+
+.if !defined(WITHOUT_EXAMPLES)
+PLIST_SUB+= EXAMPLES=""
+.else
+PLIST_SUB+= EXAMPLES="@comment "
+.endif
+
+post-patch:
+.for FILE in spicewish tcl/plot.tcl tcl/vector_test.tcl
+ @${REINPLACE_CMD} -e 's|%%WISH%%|${WISH}|g' ${WRKSRC}/src/${FILE}
+.endfor
+
+post-install:
+.if !defined(WITHOUT_EXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for FILE in README example.cir plot.tcl vector_test.tcl
+ @${INSTALL_DATA} ${WRKSRC}/src/tcl/${FILE} ${EXAMPLESDIR}
+.endfor
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.post.mk>