aboutsummaryrefslogtreecommitdiffstats
path: root/cad/tochnog/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-04-01 21:29:15 +0800
committermat <mat@FreeBSD.org>2016-04-01 21:29:15 +0800
commit96cd8e4bc2d30db4bc3bbbf3fcdcc98121c879e0 (patch)
treee5609c11a5cecf09649970cae33b72d3774969e3 /cad/tochnog/Makefile
parent734d10a8b4340cbeb3639bfaf8c7249ec7089c0a (diff)
downloadfreebsd-ports-gnome-96cd8e4bc2d30db4bc3bbbf3fcdcc98121c879e0.tar.gz
freebsd-ports-gnome-96cd8e4bc2d30db4bc3bbbf3fcdcc98121c879e0.tar.zst
freebsd-ports-gnome-96cd8e4bc2d30db4bc3bbbf3fcdcc98121c879e0.zip
Remove ${PORTSDIR}/ from dependencies, Mk and categories a, b, and c.
With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'cad/tochnog/Makefile')
-rw-r--r--cad/tochnog/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/cad/tochnog/Makefile b/cad/tochnog/Makefile
index 23990bf4be5d..9d9ce50dfaba 100644
--- a/cad/tochnog/Makefile
+++ b/cad/tochnog/Makefile
@@ -15,7 +15,7 @@ COMMENT= Free explicit/implicit Finite Element Program
LICENSE= GPLv2
-BUILD_DEPENDS= ${LOCALBASE}/lib/libf2c.a:${PORTSDIR}/lang/f2c
+BUILD_DEPENDS= ${LOCALBASE}/lib/libf2c.a:lang/f2c
OPTIONS_DEFINE= ATLAS EXAMPLES THREADS
ATLAS_DESC= Use ATLAS instead of BLAS/LAPACK
@@ -36,25 +36,25 @@ GID_PTYPES= ${PREFIX}/${GIDDIR}/problemtypes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MATLAS}
-LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:math/atlas
.if ${PORT_OPTIONS:MTHREADS}
BLAS_LIBS= -lptf77blas
.else
BLAS_LIBS= -lf77blas
.endif
.else
-LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas \
- liblapack.so:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:math/blas \
+ liblapack.so:math/lapack
BLAS_LIBS= -llapack -lblas
.endif
.if ${PORT_OPTIONS:MTHREADS}
ALL_TARGET= freebsd_parallel
-LIB_DEPENDS+= libsuperlu_mt.so:${PORTSDIR}/math/superlu_mt
+LIB_DEPENDS+= libsuperlu_mt.so:math/superlu_mt
SUPERLU= superlu_mt
.else
ALL_TARGET= freebsd_old
-LIB_DEPENDS+= libsuperlu.so:${PORTSDIR}/math/superlu
+LIB_DEPENDS+= libsuperlu.so:math/superlu
SUPERLU= superlu
.endif