aboutsummaryrefslogtreecommitdiffstats
path: root/cad/tochnog/Makefile
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-06-26 18:06:21 +0800
committernetchild <netchild@FreeBSD.org>2005-06-26 18:06:21 +0800
commitb45310d671ca773081a8290af0c4b65eb7c8ce19 (patch)
treede1bd6b64f4908b7e6810a2dd90084a62e74e7de /cad/tochnog/Makefile
parent042f25e707eb4e49cef8b2869741906559664a0b (diff)
downloadfreebsd-ports-gnome-b45310d671ca773081a8290af0c4b65eb7c8ce19.tar.gz
freebsd-ports-gnome-b45310d671ca773081a8290af0c4b65eb7c8ce19.tar.zst
freebsd-ports-gnome-b45310d671ca773081a8290af0c4b65eb7c8ce19.zip
The tochnog port installs some plugins into a directory which is owned by
the the cad/linux-gid port, but it doesn't adds a dependency to linux-gid, since tochnog can be used standalone. The right thing to do would be to add a slave port which installs the plugins only. The slave port would have to depend upon linux-gid and tochnog. Since the linux-gid port installs now in X11BASE and tochnog installs in LOCALBASE, we have a plist problem ATM too. In light of the recent discussion about the right base directory for ports which use X11 bits I decided to go the quick route until everything is decided: - move linux-gid back to LOCALBASE - let tochnog still install the plugins This reverts back to the status quo (a working tochnog/linux-gid). Someone with a good asbestos suite may want to mark the tochnog port BROKEN. Dependencies explained by: pfgshield-freebsd@yahoo.com
Diffstat (limited to 'cad/tochnog/Makefile')
-rw-r--r--cad/tochnog/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/cad/tochnog/Makefile b/cad/tochnog/Makefile
index 2551893d8157..d6ef866319e5 100644
--- a/cad/tochnog/Makefile
+++ b/cad/tochnog/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tochnog
PORTVERSION= 20010211
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= cad
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tochnog
@@ -24,6 +24,13 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libsuperlu.a:${PORTSDIR}/math/superlu
.endif
LIB_DEPENDS= atlas:${PORTSDIR}/math/atlas
+# This port installs some plugins into a directory which is owned by the
+# the cad/linux-gid port, but it doesn't adds a dependency to linux-gid,
+# since tochnog can be used standalone.
+# The right thing to do would be to add a slave port which installs the
+# plugins only. The slave port would have to depend upon linux-gid and
+# tochnog.
+
USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}/src
MAKEFILE= makefile
@@ -31,7 +38,7 @@ MAKEFILE= makefile
GIDDIR?= share/gid
PLIST_SUB+= GIDDIR=${GIDDIR}
-GID_PREFIX?= ${X11BASE}/${GIDDIR}/problemtypes
+GID_PREFIX?= ${LOCALBASE}/${GIDDIR}/problemtypes
.ifdef WITH_THREADS
BLAS_LIBS?= -L${LOCALBASE}/lib -lptf77blas -latlas_r