aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2018-06-14 20:47:58 +0800
committertijl <tijl@FreeBSD.org>2018-06-14 20:47:58 +0800
commit118df57fa4a8439a5b0ddd13a6c2d843bdb5f853 (patch)
tree887d2ee07449ef7ef155da1e40fc852d2d19c539 /cad
parent37fc2f23670f59cd2f0e4c67e6d99449e0a5a9f2 (diff)
downloadfreebsd-ports-gnome-118df57fa4a8439a5b0ddd13a6c2d843bdb5f853.tar.gz
freebsd-ports-gnome-118df57fa4a8439a5b0ddd13a6c2d843bdb5f853.tar.zst
freebsd-ports-gnome-118df57fa4a8439a5b0ddd13a6c2d843bdb5f853.zip
Update automake to 1.16.1. Also remove automake-wrapper. We haven't had
multiple versions of automake in years and probably won't in the future. PR: 228809 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'cad')
-rw-r--r--cad/repsnapper/Makefile8
-rw-r--r--cad/repsnapper/files/patch-configure.ac25
2 files changed, 29 insertions, 4 deletions
diff --git a/cad/repsnapper/Makefile b/cad/repsnapper/Makefile
index bdd6bfd79604..ad2f30bfb670 100644
--- a/cad/repsnapper/Makefile
+++ b/cad/repsnapper/Makefile
@@ -3,7 +3,7 @@
PORTNAME= repsnapper
DISTVERSION= 2.5a4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= cad
MAINTAINER= martin.dieringer@gmx.de
@@ -13,19 +13,19 @@ LICENSE= GPLv2 BSD3CLAUSE MIT
LICENSE_COMB= multi
LIB_DEPENDS= libgtkglextmm-x11-1.2.so:x11-toolkits/gtkglextmm \
+ libpolyclipping.so:graphics/polyclipping \
libzip.so:archivers/libzip
-BUILD_DEPENDS+= clang40:devel/llvm40
USE_GITHUB= yes
GH_ACCOUNT= timschmidt
-USES= compiler:c++11-lib autoreconf gmake libtool perl5 pkgconfig gettext
+USES= compiler:c++11-lib autoreconf gettext gmake libtool localbase \
+ perl5 pkgconfig
USE_GNOME= gtkmm24 intltool libxml++26
USE_GL= gl
USE_PERL5= build
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
diff --git a/cad/repsnapper/files/patch-configure.ac b/cad/repsnapper/files/patch-configure.ac
new file mode 100644
index 000000000000..4c8f5f5b225e
--- /dev/null
+++ b/cad/repsnapper/files/patch-configure.ac
@@ -0,0 +1,25 @@
+--- configure.ac.orig 2017-06-02 13:20:16 UTC
++++ configure.ac
+@@ -30,9 +30,6 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE"
+ case "$host_os" in
+ freebsd*)
+ # Using clang:
+- CC=clang40
+- CPP=clang-cpp40
+- CXX=clang++40
+ # or gcc5:
+ # CC=gcc5
+ # CPP=cpp5
+@@ -52,9 +49,12 @@ AC_TYPE_SSIZE_T
+ dnl check for installed clipperlib newer than 5.1.0 (has PolyNode)
+ AC_DEFINE([HAVE_CLIPPERLIB],[0],[Have external clipper])
+ CLIPPER_LIBS="libclipper.la"
++saved_LIBS=$LIBS
++LIBS="-lpolyclipping $LIBS"
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <polyclipping/clipper.hpp>], [ClipperLib::PolyNode cnode])],
+ [AC_DEFINE([HAVE_CLIPPERLIB],[1]) CLIPPER_LIBS="-lpolyclipping"],
+ [AC_MSG_WARN([libclipper is not installed. Using internal copy.])])
++LIBS=$saved_LIBS
+ AC_SUBST(CLIPPER_LIBS)
+
+