aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-03-10 04:47:09 +0800
committertcberner <tcberner@FreeBSD.org>2018-03-10 04:47:09 +0800
commit282bc9e47a1e3bf8f11164aecee20855ef2359b5 (patch)
tree550b6ebe5e98b36c015ff8c1935beeb7606f7363 /cad
parentf30dbea3f2ab5827a6b14deff01ce1410c5ce726 (diff)
downloadfreebsd-ports-gnome-282bc9e47a1e3bf8f11164aecee20855ef2359b5.tar.gz
freebsd-ports-gnome-282bc9e47a1e3bf8f11164aecee20855ef2359b5.tar.zst
freebsd-ports-gnome-282bc9e47a1e3bf8f11164aecee20855ef2359b5.zip
Fix cad/openscad shebang
Error: '/usr/local/bin/python' is an invalid shebang you need USES=shebangfix for 'share/openscad/libraries/MCAD/get_submodules.py The existing shebang fix on the py file did nothing without USES=python. Python already was an implied dependency. Approved by: portmgr blanket
Diffstat (limited to 'cad')
-rw-r--r--cad/openscad/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/cad/openscad/Makefile b/cad/openscad/Makefile
index 8ab500193ee5..5254ed1766a4 100644
--- a/cad/openscad/Makefile
+++ b/cad/openscad/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openscad
PORTVERSION= 2015.03
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= cad
MASTER_SITES= http://files.openscad.org/
DISTNAME= openscad-${PORTVERSION}.src
@@ -23,7 +23,8 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libharfbuzz.so:print/harfbuzz \
libopencsg.so:graphics/opencsg
-USES= bison compiler:c++11-lang desktop-file-utils eigen:3 gettext-tools pkgconfig qmake shebangfix
+USES= bison compiler:c++11-lang desktop-file-utils eigen:3 gettext-tools \
+ pkgconfig python:run qmake shebangfix
SHEBANG_FILES= libraries/MCAD/get_submodules.py
USE_GL= glu glew
USE_QT4= corelib gui opengl moc_build uic_build rcc_build