aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2008-05-06 00:08:43 +0800
committerhrs <hrs@FreeBSD.org>2008-05-06 00:08:43 +0800
commit5e139cfb527fd1b9be56a6206f44b99864fcc9f4 (patch)
tree11af398909ab96e9158b86aa852e88243e601ecb /cad
parente0aedc84c1c21c93cbd8faabcc8ca5c4de45680e (diff)
downloadfreebsd-ports-gnome-5e139cfb527fd1b9be56a6206f44b99864fcc9f4.tar.gz
freebsd-ports-gnome-5e139cfb527fd1b9be56a6206f44b99864fcc9f4.tar.zst
freebsd-ports-gnome-5e139cfb527fd1b9be56a6206f44b99864fcc9f4.zip
Update to 0.14. Changes since version 0.10 include:
* Several RBA extensions: i.e. alternative methods replacing different 'new' variants by one 'new'. Markers now can be filled. * Fixes for the bugs mentioned in the issues list. * OASIS and GDS writing capabilities. Menu functions are provided to save a layout and single cells as well as RBA extensions that allow to write a layout. See Saving a layout or parts of it for details. * Rulers and markers are drawn with a thin halo in background color to enhance their visibility. This can be switched off in the setup dialog if this is not desired. The following screenshots illustrate the differences: * A couple of RBA extensions: API's for shape properties, rulers and geometry selections. * A bugfix for the OASIS reader (sometimes crashing the reader on CBLOCK-compressed input) * A function to descend into a cell in the hierarchy but keeping the context, which is shown in dimmed colors. This function can be found in the "Display" menu and is called "Descend". To use this function, select a shape or instance inside the cell into which to descend. "Descend" then enters the next cell along the path that leads to the selected shape or instance. * The mouse wheel can be used to zoom in and out. * Shift+right mouse button pressed now allows to "drag" layout in a "Google maps" fashion. * Copy & paste now is available for layers as well. * A ruby console is provided where ruby commands can be executed interactively. * The way how the selection is displayed can be configured now (color, line width and vertex size). * The interrupt signal now is enabled again even if Ruby is activated (Ctrl+C now works again). * Support for arbitrary angles on cell instances. * A bugfix for the OASIS reader (CTRAPEZOIDS have not been read in some cases). The OASIS reader now uses shape arrays to acchieve are smaller memory footprint in some cases. * Multiple transformations are now allowed on layer source expressions (see Transforming views and property selectors for a detailed description). * Rulers now are configurable to a large extent. Multiple ruler templates may be defined from which a certain ruler type can be choosen. Some of the new ruler styles are no longer "rulers" but rather "annotations". See Ruler properties for a description of that feature. * Last, but not least: KLayout now can be scripted to some extend using Ruby as the scripting language. For more information about this feature, see RBA introduction. * Some bugs were fixed in the OASIS implementation. CBLOCK compression now is supported. Forward cell name references (numerical ID is used before being associated with a string) are supported as now. File global properties are now read correctly. A bug reading certain CTRAPEZOID objects was fixed. (Still, forward references are not allowed for text/property strings or property names). * A layout properties dialog has been added that shows basic properties of the layout such as top cells, layers and others. * The "Select Cell" dialog has been enhanced with the capability to hide and show multiple cells in the cell list. * A "zoom fit" mouse gesture was implemented: moving the mouse up and right with the right mouse button pressed now fits the current cell into the window. Moving up and left still zooms out. * A bug in the GDS2 reader, dropping polygon points in rare cases, was fixed
Diffstat (limited to 'cad')
-rw-r--r--cad/klayout/Makefile2
-rw-r--r--cad/klayout/distinfo6
-rw-r--r--cad/klayout/files/patch-build.sh29
-rw-r--r--cad/klayout/files/patch-config-Makefile.conf10
-rw-r--r--cad/klayout/files/patch-src-Makefile.rules18
5 files changed, 32 insertions, 33 deletions
diff --git a/cad/klayout/Makefile b/cad/klayout/Makefile
index b914d3706d3c..92c5b8c9e09c 100644
--- a/cad/klayout/Makefile
+++ b/cad/klayout/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= klayout
-PORTVERSION= 0.10
+PORTVERSION= 0.14
CATEGORIES= cad
MASTER_SITES= http://www.klayout.de/
diff --git a/cad/klayout/distinfo b/cad/klayout/distinfo
index 74a8f101bb7e..af39cc91f4dd 100644
--- a/cad/klayout/distinfo
+++ b/cad/klayout/distinfo
@@ -1,3 +1,3 @@
-MD5 (klayout-0.10.tar.gz) = b8bf7f9b3830840eabd245e9114ca6f6
-SHA256 (klayout-0.10.tar.gz) = a6a5bae4ffb4bedbd6b204b9c14d1355ad665bb47412800c6bea4f906516778c
-SIZE (klayout-0.10.tar.gz) = 454804
+MD5 (klayout-0.14.tar.gz) = 0c0fa79aabc67ff42dc613cd2ed567cb
+SHA256 (klayout-0.14.tar.gz) = fecbcdf2d9a33627bfa7ee45c8282c5112c9faad37e2ac4727576dd20f5a3cb3
+SIZE (klayout-0.14.tar.gz) = 766242
diff --git a/cad/klayout/files/patch-build.sh b/cad/klayout/files/patch-build.sh
index e0d4374c06ef..cd6495b21678 100644
--- a/cad/klayout/files/patch-build.sh
+++ b/cad/klayout/files/patch-build.sh
@@ -1,33 +1,32 @@
---- build.sh.orig Tue May 8 04:41:18 2007
-+++ build.sh Sat Jun 2 16:43:04 2007
-@@ -77,12 +77,12 @@
+--- build.sh.orig Fri Nov 9 04:31:36 2007
++++ build.sh Sun Jan 6 18:57:53 2008
+@@ -126,11 +126,11 @@
exit 1
fi
--if [ ! -r $QTDIR/bin/moc ]; then
-+if [ ! -r $QTDIR/bin/moc-qt4 ]; then
- echo "*** ERROR: unable to locate Qt MOC in $QTDIR/bin"
+-if [ ! -r $QTBIN/moc ]; then
++if [ ! -r $QTBIN/moc-qt4 ]; then
+ echo "*** ERROR: unable to locate Qt MOC in $QTBIN"
exit 1
fi
-
--if [ ! -r $QTDIR/bin/uic ]; then
-+if [ ! -r $QTDIR/bin/uic-qt4 ]; then
- echo "*** ERROR: unable to locate Qt UIC in $QTDIR/bin"
+-if [ ! -r $QTBIN/uic ]; then
++if [ ! -r $QTBIN/uic-qt4 ]; then
+ echo "*** ERROR: unable to locate Qt UIC in $QTBIN"
exit 1
fi
-@@ -153,12 +153,12 @@
+@@ -231,12 +231,12 @@
echo "Build done."
echo ""
echo "Final binary is ready in $BIN/$EXEC_NAME."
- echo "To run it, you may need to add the following to your LD_LIBRARY_PATH:"
-- echo "$QTDIR/lib"
+- echo "$QTLIB"
+ #echo "To run it, you may need to add the following to your LD_LIBRARY_PATH:"
-+ #echo "$QTDIR/lib"
++ #echo "$QTLIB"
-- LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
+- LD_LIBRARY_PATH=$QTLIB:$LD_LIBRARY_PATH
- $BIN/$EXEC_NAME -v
- $BIN/$EXEC_NAME -h
-+ #LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
++ #LD_LIBRARY_PATH=$QTLIB:$LD_LIBRARY_PATH
+ #$BIN/$EXEC_NAME -v
+ #$BIN/$EXEC_NAME -h
diff --git a/cad/klayout/files/patch-config-Makefile.conf b/cad/klayout/files/patch-config-Makefile.conf
index 18ebee5a12e1..ee33004ce34d 100644
--- a/cad/klayout/files/patch-config-Makefile.conf
+++ b/cad/klayout/files/patch-config-Makefile.conf
@@ -1,6 +1,7 @@
---- /dev/null Sat Jun 2 16:46:55 2007
-+++ config/Makefile.conf.freebsd-32-gcc-release Sat Jun 2 16:49:48 2007
+--- /dev/null 2008-05-05 02:46:45.000000000 +0900
++++ config/Makefile.conf.freebsd-32-gcc-release 2008-05-05 02:47:41.000000000 +0900
@@ -0,0 +1,23 @@
++AR=ar -r
+CC=gcc
+
+CCOPT_DEP=-MM -MG -x c++
@@ -11,7 +12,7 @@
+CCOPT=-c -O -x c++ -o
+CCOPT_SO=-fPIC $(CCOPT)
+
-+INC=-I$(TOP_SOURCE) -I$(SOURCE) -I. -I$(QTDIR)/include
++INC=-I$(TOP_SOURCE) -I$(SOURCE) -I. -I$(QTINCLUDE)
+
+DEFS=-DQT_THREAD_SUPPORT -DQT3_SUPPORT
+
@@ -22,5 +23,4 @@
+LOPT=-Wl,-E -o
+LOPT_SO=-shared -fPIC -o
+
-+LIBS=-L$(QTDIR)/lib -pthread -lQt3Support -lQtGui -lQtCore -lQtXml -lstdc++
-+
++LIBS=-L$(QTLIB) -pthread -lQtGui -lQtCore -lQtXml -lrt -lstdc++ -lcrypt
diff --git a/cad/klayout/files/patch-src-Makefile.rules b/cad/klayout/files/patch-src-Makefile.rules
index 4bf96bf5ce62..a2a1cdd97062 100644
--- a/cad/klayout/files/patch-src-Makefile.rules
+++ b/cad/klayout/files/patch-src-Makefile.rules
@@ -1,13 +1,13 @@
---- src/Makefile.rules.orig Tue May 8 04:41:19 2007
-+++ src/Makefile.rules Sat Jun 2 16:45:56 2007
-@@ -16,8 +16,8 @@
- endif
+--- src/Makefile.rules.orig Fri Nov 9 04:31:39 2007
++++ src/Makefile.rules Sun Jan 6 18:59:35 2008
+@@ -25,8 +25,8 @@
CCOPTS=$(CCWARN) $(DEFS) $(CCOPT)
+ CCOPTS_DEP=$(DEFS) $(CCOPT_DEP)
--MOC=$(QTDIR)/bin/moc
--UIC=$(QTDIR)/bin/uic
-+MOC=$(QTDIR)/bin/moc-qt4
-+UIC=$(QTDIR)/bin/uic-qt4
- RCC=$(QTDIR)/bin/rcc
+-MOC=$(QTBIN)/moc
+-UIC=$(QTBIN)/uic
++MOC=$(QTBIN)/moc-qt4
++UIC=$(QTBIN)/uic-qt4
+ RCC=$(QTBIN)/rcc
# this target must be first: