aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2006-07-15 00:18:00 +0800
committerahze <ahze@FreeBSD.org>2006-07-15 00:18:00 +0800
commit7a2a3d2c4f5aa74396db5cc6ac70e40c9650110f (patch)
treeb383407f41df92b60217efdb7f69d810a61e1832 /cad
parent0b7cacaba73e3e1900bf56cccca849d2c66413aa (diff)
downloadfreebsd-ports-gnome-7a2a3d2c4f5aa74396db5cc6ac70e40c9650110f.tar.gz
freebsd-ports-gnome-7a2a3d2c4f5aa74396db5cc6ac70e40c9650110f.tar.zst
freebsd-ports-gnome-7a2a3d2c4f5aa74396db5cc6ac70e40c9650110f.zip
- fix build on sparc64
PR: 99971 Submitted by: ahze Approved by: maintainer
Diffstat (limited to 'cad')
-rw-r--r--cad/brlcad/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/cad/brlcad/Makefile b/cad/brlcad/Makefile
index e8074a4f0d94..0020ab6b551e 100644
--- a/cad/brlcad/Makefile
+++ b/cad/brlcad/Makefile
@@ -29,7 +29,7 @@ INSTALLS_SHLIB= yes # Not really useful, but pet portlint
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.4
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS+=--with-libs="-lpng" --program-transform-name="" \
+CONFIGURE_ARGS+=--with-libs="-lpng ${EXTRA_LIBS}" --program-transform-name="" \
--disable-jove-build
PLIST_SUB+= PORTVERSION=${PORTVERSION}
@@ -158,16 +158,20 @@ OPTIONS= OPTIMIZATION "Try building with optimizations" on
.include <bsd.port.pre.mk>
+.if ${ARCH} == sparc64
+EXTRA_LIBS= ${PTHREAD_LIBS}
+.endif
+
# we only run on i386 and amd64 release 5+
.if ${OSVERSION} < 500000
BROKEN= Does not compile on FreeBSD-${OSREL}
-.elif !(${ARCH} == i386 || ${ARCH} == amd64)
+.elif !(${ARCH} == i386 || ${ARCH} == amd64 || ${ARCH} == sparc64)
IGNORE= dumps core on ${ARCH}
.endif
.ifdef WITH_OPTIMIZATION
CONFIGURE_ARGS+= --disable-debug
-.if (${ARCH} == i386 || ${ARCH} == amd64)
+.if (${ARCH} == i386 || ${ARCH} == amd64 || ${ARCH} == sparc64)
CONFIGURE_ARGS+= --enable-optimized
.endif
.endif