aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-05-06 06:50:59 +0800
committertijl <tijl@FreeBSD.org>2014-05-06 06:50:59 +0800
commitc236950c29ab1f8ab4a24f49e5af43a8d1bf8cf9 (patch)
tree49ebd32e9d1eaacd803588c4fa128f8aa078e430 /cad
parent674cfcefeea614d6e90d5c2ee6285973d91bc3ef (diff)
downloadfreebsd-ports-gnome-c236950c29ab1f8ab4a24f49e5af43a8d1bf8cf9.tar.gz
freebsd-ports-gnome-c236950c29ab1f8ab4a24f49e5af43a8d1bf8cf9.tar.zst
freebsd-ports-gnome-c236950c29ab1f8ab4a24f49e5af43a8d1bf8cf9.zip
Convert archivers/libzip to USES=libtool. Bump PORTREVISION on all
dependent ports. cad/repsnapper: - Remove excessive dependencies. - Convert to USES=libtool. - Set LDFLAGS to fix detection of libintl. - Use @sample. databases/mysql-workbench51: - Remove remnants of former slave ports. - Convert some LIB_DEPENDS to USE_GNOME. - Convert to USES=libtool. - Staging. databases/mysql-workbench52: - USES=libtool. devel/libsigrok: - USES=libtool. - INSTALL_TARGET=install-strip. devel/liborcus: - USES=libtool tar:bzip2.
Diffstat (limited to 'cad')
-rw-r--r--cad/repsnapper/Makefile42
-rw-r--r--cad/repsnapper/pkg-plist4
2 files changed, 10 insertions, 36 deletions
diff --git a/cad/repsnapper/Makefile b/cad/repsnapper/Makefile
index 66e7e45299d1..9b900db2a6ca 100644
--- a/cad/repsnapper/Makefile
+++ b/cad/repsnapper/Makefile
@@ -3,7 +3,7 @@
PORTNAME= repsnapper
PORTVERSION= 2.3.2a3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= cad
MASTER_SITES= https://codeload.github.com/timschmidt/repsnapper/tar.gz/
DISTNAME= ${PORTVERSION}
@@ -16,32 +16,17 @@ COMMENT= Controller and GCode generator for RepRap 3D printers
LICENSE= GPLv2 BSD MIT
LICENSE_COMB= multi
-BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
LIB_DEPENDS= libgtkglextmm-x11-1.2.so:${PORTSDIR}/x11-toolkits/gtkglextmm \
- libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24 \
- libglademm-2.4.so:${PORTSDIR}/devel/libglademm24 \
- libcairomm-1.0.so:${PORTSDIR}/graphics/cairomm \
libzip.so:${PORTSDIR}/archivers/libzip \
- libatkmm-1.6.so:${PORTSDIR}/accessibility/atkmm \
- libglibmm-2.4.so:${PORTSDIR}/devel/glibmm \
- libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
- libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
- libpcre.so:${PORTSDIR}/devel/pcre \
- libdrm.so:${PORTSDIR}/graphics/libdrm \
- libpng15.so:${PORTSDIR}/graphics/png \
- libfreetype.so:${PORTSDIR}/print/freetype2 \
- libexpat.so:${PORTSDIR}/textproc/expat2 \
- libxml++-2.6.so:${PORTSDIR}/textproc/libxml++26 \
- libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
- libpangomm-1.4.so:${PORTSDIR}/x11-toolkits/pangomm
-USES= gmake pkgconfig iconv
-USE_GNOME= gdkpixbuf2 gtk20 libxml2
+USES= gmake libtool perl5 pkgconfig
+USE_AUTOTOOLS= libtoolize:env autoconf:env automake:env
+USE_GNOME= gtkmm24 libxml++26
USE_GL= gl
-USE_AUTOTOOLS= automake libtool
-USE_XORG= ice pixman sm x11 xau xcb xcomposite xcursor xdamage xdmcp \
- xext xfixes xi xinerama xmu xrandr xrender xt xxf86vm
+USE_PERL5= build
+GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
+LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
@@ -50,21 +35,12 @@ NLS_USES= gettext
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
INSTALL_TARGET= install-strip
-CONFIGURE_ARGS= --prefix=${PREFIX}
pre-configure:
- cd ${WRKSRC} && ./autogen.sh
-
-post-configure:
- @${REINPLACE_CMD} 's|src/repsnapper.conf||' \
- ${WRKSRC}/Makefile
- @${REINPLACE_CMD} 's|DATADIRNAME = lib|DATADIRNAME = share|' \
- ${WRKSRC}/po/Makefile
+ cd ${WRKSRC} && ${SETENV} NOCONFIGURE=yes ./autogen.sh
post-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/etc/xdg/repsnapper
- ${INSTALL_DATA} ${WRKSRC}/src/repsnapper.conf \
+ ${MV} ${STAGEDIR}${PREFIX}/etc/xdg/repsnapper/repsnapper.conf \
${STAGEDIR}${PREFIX}/etc/xdg/repsnapper/repsnapper.conf.sample
-
.include <bsd.port.mk>
diff --git a/cad/repsnapper/pkg-plist b/cad/repsnapper/pkg-plist
index ddf52c44c3a6..74196559e8a3 100644
--- a/cad/repsnapper/pkg-plist
+++ b/cad/repsnapper/pkg-plist
@@ -1,7 +1,5 @@
bin/repsnapper
-@unexec if cmp -s %D/etc/xdg/repsnapper/repsnapper.conf.sample %D/etc/xdg/repsnapper/repsnapper.conf; then rm -f %D/etc/xdg/repsnapper/repsnapper.conf; fi
-etc/xdg/repsnapper/repsnapper.conf.sample
-@exec if [ ! -f %D/etc/xdg/repsnapper/repsnapper.conf ] ; then cp -p %D/%F %B/repsnapper.conf; fi
+@sample etc/xdg/repsnapper/repsnapper.conf.sample
share/applications/repsnapper.desktop
%%NLS%%share/locale/en_GB/LC_MESSAGES/repsnapper.mo
%%NLS%%share/locale/de_DE/LC_MESSAGES/repsnapper.mo