aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-03-07 08:40:29 +0800
committernemysis <nemysis@FreeBSD.org>2014-03-07 08:40:29 +0800
commitc3294c1b69e6ed2c4da2e1d25deff6115fecc6ec (patch)
tree415698e9ed676483700ca71197b67e5a537dc3d8 /cad
parent61b4055dc021c4b5e6ac0aab64403becf4d9334f (diff)
downloadfreebsd-ports-gnome-c3294c1b69e6ed2c4da2e1d25deff6115fecc6ec.tar.gz
freebsd-ports-gnome-c3294c1b69e6ed2c4da2e1d25deff6115fecc6ec.tar.zst
freebsd-ports-gnome-c3294c1b69e6ed2c4da2e1d25deff6115fecc6ec.zip
- Update to 0.80.2, Announce message:
Added Look At command. Added orthographic projection option. Added editing of group names from the Edit Group Dialog. Fixed wrong transform of some pieces when importing nested LDraw files. Fixed printing and saving images on certain Intel video cards. Fixed grid studs being enabled by grid lines option. Fixed piece arrows not being drawn if the axis icon is enabled. Preserve groups when merging. Note that due to changes in Google Code I had to switch to Google Drive to host the files and I'll probably close the project there so if you had any links/bookmarks pointing to that page please update them. - Change master site from GOOGLE_CODE to my SF site, have used svn download from Trac and Google Drive for pieces - Add OPTIONS_SINGLE=LIBRARY and LDRAW, LEOCAD Options - Change dependency for cad/ldraw, only for LDRAW Option - Change dependency for archivers/unzip, only for LEOCAD Option - Change REINPLACE - Remove obsolete patch, changed by upstream, the /usr change was a request from the Debian maintainers
Diffstat (limited to 'cad')
-rw-r--r--cad/leocad/Makefile42
-rw-r--r--cad/leocad/distinfo8
-rw-r--r--cad/leocad/files/patch-qt-qtmain.cpp13
3 files changed, 34 insertions, 29 deletions
diff --git a/cad/leocad/Makefile b/cad/leocad/Makefile
index bfa30bad6e14..2ee65ac5b714 100644
--- a/cad/leocad/Makefile
+++ b/cad/leocad/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= leocad
-PORTVERSION= 0.80.1
+PORTVERSION= 0.80.2
CATEGORIES= cad
-MASTER_SITES= GOOGLE_CODE
-DISTFILES= ${PORTNAME}-${PORTVERSION}-src.tgz \
- ${LEOCAD_PIECES}
+MASTER_SITES= SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/
+DISTFILES= ${PORTNAME}-${PORTVERSION}-src.tgz
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}-src.tgz
@@ -15,18 +14,14 @@ COMMENT= CAD program that uses bricks similar to those found in many toys
LICENSE= GPLv2
-EXTRACT_DEPENDS=${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng15.so:${PORTSDIR}/graphics/png
-RUN_DEPENDS= ${LOCALBASE}/share/ldraw/models/car.dat:${PORTSDIR}/cad/ldraw
WRKSRC= ${WRKDIR}/${PORTNAME}
-LEOCAD_PIECES= pieces-7439.zip
USES= desktop-file-utils gmake pkgconfig qmake shared-mime-info
USE_QT4= moc_build rcc_build uic_build iconengines_run imageformats_run \
corelib gui network opengl
-
USE_GL= glut
USE_GNOME= gtk20
@@ -34,18 +29,35 @@ PORTDOCS= CREDITS.txt README.txt TODO.txt
OPTIONS_DEFINE= DOCS
+OPTIONS_SINGLE= LIBRARY
+OPTIONS_SINGLE_LIBRARY= LDRAW LEOCAD
+OPTIONS_DEFAULT= LEOCAD
+
+LDRAW_DESC= Library from LDraw symlink, mostly fewer pieces
+LEOCAD_DESC= Library from LeoCad file, mostly more pieces
+
INSTALLS_ICONS= yes
ICON_SIZES= 16x16 24x24 32x32 48x48 128x128 256x256
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MLDRAW}
+RUN_DEPENDS= ${LOCALBASE}/share/ldraw/models/car.dat:${PORTSDIR}/cad/ldraw
+.endif
+
+.if ${PORT_OPTIONS:MLEOCAD}
+LEOCAD_PIECES= Library-Linux-7931.zip
+DISTFILES+= ${LEOCAD_PIECES}
+EXTRACT_DEPENDS=${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
post-extract:
@${UNZIP_CMD} -q -o ${_DISTDIR}/${LEOCAD_PIECES} -d ${WRKDIR}/pieces
+.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/usr|${PREFIX}|' \
- -e 's|share/man/man1|man/man1|' \
+ @${REINPLACE_CMD} -e 's|/usr|${PREFIX}|; \
+ s|share/man/man1|man/man1|; \
+ s|docs.files = docs/README.txt docs/CREDITS.txt docs/COPYING.txt|docs.files = |' \
${WRKSRC}/${PORTNAME}.pro
- @${REINPLACE_CMD} -e 's|docs.files = docs/README.txt docs/CREDITS.txt docs/COPYING.txt|docs.files = |' \
- ${WRKSRC}/${PORTNAME}.pro
.for s in 16 24 32 48 128 256
@cd ${WRKSRC}/tools/icon && \
@@ -56,7 +68,13 @@ post-patch:
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
+
+.if ${PORT_OPTIONS:MLDRAW}
+ ${LN} -s ${PREFIX}/share/ldraw ${STAGEDIR}${DATADIR}/library.bin
+.endif
+.if ${PORT_OPTIONS:MLEOCAD}
${INSTALL_DATA} ${WRKDIR}/pieces/* ${STAGEDIR}${DATADIR}
+.endif
.for s in ${ICON_SIZES}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps
diff --git a/cad/leocad/distinfo b/cad/leocad/distinfo
index f68b8ef8064f..c78aaadea144 100644
--- a/cad/leocad/distinfo
+++ b/cad/leocad/distinfo
@@ -1,4 +1,4 @@
-SHA256 (leocad/leocad-0.80.1-src.tgz) = e1db5db1ad9bf9b25eb760b88a4833caeba4e9b96bc793e76c9622a0160bc160
-SIZE (leocad/leocad-0.80.1-src.tgz) = 963073
-SHA256 (leocad/pieces-7439.zip) = f826115999296800a8cb22a85521eb019d8fbeb91e8a92d3485bcbf0e94a15fd
-SIZE (leocad/pieces-7439.zip) = 22023619
+SHA256 (leocad/leocad-0.80.2-src.tgz) = 8f4bdea7f1259da62fb158e19e8f869fccb99fa33073a4db29190bee1ee16f30
+SIZE (leocad/leocad-0.80.2-src.tgz) = 965872
+SHA256 (leocad/Library-Linux-7931.zip) = 3afa911f0c8064392a54937fdff305066cd8e910d66b1dafd7dbb5758c4b7456
+SIZE (leocad/Library-Linux-7931.zip) = 24226538
diff --git a/cad/leocad/files/patch-qt-qtmain.cpp b/cad/leocad/files/patch-qt-qtmain.cpp
deleted file mode 100644
index b44503f9028c..000000000000
--- a/cad/leocad/files/patch-qt-qtmain.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- qt/qtmain.cpp.orig 2013-08-13 06:54:12.000000000 +0200
-+++ qt/qtmain.cpp 2013-08-30 23:52:45.000000000 +0200
-@@ -149,6 +149,10 @@
- const char* libPath = LC_INSTALL_PREFIX"/share/leocad/";
- #endif
-
-+#ifdef Q_OS_FREEBSD
-+ const char* libPath = LC_INSTALL_PREFIX"/local/share/leocad/";
-+#endif
-+
- #ifdef Q_OS_MAC
- QDir bundlePath = QDir(QCoreApplication::applicationDirPath());
- bundlePath.cdUp();