aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-03-24 20:05:21 +0800
committerpawel <pawel@FreeBSD.org>2014-03-24 20:05:21 +0800
commitc67029a9fa9dcf31a086a6ebf7ed806bc472efc6 (patch)
treeb643340aad97cfd329cf00b2749c337684dd8663 /cad
parent33b95cbfcf366995595e0a936429c934afb7485f (diff)
downloadfreebsd-ports-gnome-c67029a9fa9dcf31a086a6ebf7ed806bc472efc6.tar.gz
freebsd-ports-gnome-c67029a9fa9dcf31a086a6ebf7ed806bc472efc6.tar.zst
freebsd-ports-gnome-c67029a9fa9dcf31a086a6ebf7ed806bc472efc6.zip
- Add staging support
- Use option helper - Switch to PORTDATA, add missing files to PLIST_FILES
Diffstat (limited to 'cad')
-rw-r--r--cad/impact/Makefile33
1 files changed, 13 insertions, 20 deletions
diff --git a/cad/impact/Makefile b/cad/impact/Makefile
index 98ea2c9d1f30..117882447812 100644
--- a/cad/impact/Makefile
+++ b/cad/impact/Makefile
@@ -33,36 +33,29 @@ SUB_FILES= impact impactgui
PLIST_FILES= bin/impact \
bin/impactgui \
- share/pixmaps/impact.png
-
-OPTIONS_DEFINE= GMSH
-
-GMSH_DESC= Enable automatic 3D finite element mesh generator
+ share/pixmaps/impact.png \
+ ${DATADIR_REL}/.classpath \
+ ${DATADIR_REL}/.project \
+ ${DATADIR_REL}/.vcm_meta
+PORTDATA= *
DESKTOP_ENTRIES="Impact" "${COMMENT}" "${PORTNAME}" \
"${PORTNAME}gui" "Graphics;3DGraphics;Education;" false
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= GMSH
-.if ${PORT_OPTIONS:MGMSH}
-RUN_DEPENDS+= gmsh:${PORTSDIR}/cad/gmsh
-.endif
+GMSH_DESC= Automatic 3D finite element mesh generator
+GMSH_RUN_DEPENDS= gmsh:${PORTSDIR}/cad/gmsh
post-extract:
@${FIND} ${WRKSRC} -name CVS -type d -print0 -or -name .cvsignore -type f -print0 | \
${XARGS} -0 ${RM} -rf
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/impact ${WRKDIR}/impactgui ${PREFIX}/bin
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${DATADIR})
-
-post-install:
- ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
-
- @${FIND} ${DATADIR} ! -type d | \
- ${SED} 's|^${PREFIX}/||' >> ${TMPPLIST}
- @${FIND} ${DATADIR} -type d | ${SORT} -r | \
- ${SED} 's|^${PREFIX}/|@dirrm |' >> ${TMPPLIST}
+ (cd ${WRKDIR} && ${INSTALL_SCRIPT} impact impactgui \
+ ${STAGEDIR}${PREFIX}/bin)
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps
.include <bsd.port.mk>