aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-12-25 23:00:20 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-12-25 23:00:20 +0800
commitdbc2f77816cb16459a83c2b10de03f7fcca95422 (patch)
tree107c5e6cc51517745de66f9e8595addb488a7fdc /cad
parent76578600ba0a1f0b3020430f1ee3de6fc6a55e7c (diff)
downloadfreebsd-ports-gnome-dbc2f77816cb16459a83c2b10de03f7fcca95422.tar.gz
freebsd-ports-gnome-dbc2f77816cb16459a83c2b10de03f7fcca95422.tar.zst
freebsd-ports-gnome-dbc2f77816cb16459a83c2b10de03f7fcca95422.zip
- Switch to options helpers
- Switch to new test framework
Diffstat (limited to 'cad')
-rw-r--r--cad/sceptre/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/cad/sceptre/Makefile b/cad/sceptre/Makefile
index f8cdc7191d35..3f0f7f2ad97b 100644
--- a/cad/sceptre/Makefile
+++ b/cad/sceptre/Makefile
@@ -19,6 +19,7 @@ NO_WRKSUBDIR= yes
FFLAGS+= -fno-automatic
PORTDOCS= doc_en.pdf doc_ger.pdf install.pdf
+
OPTIONS_DEFINE= DOCS
post-patch:
@@ -44,15 +45,14 @@ post-patch:
-e "s!^(FC=')(.*)(')!\1${FC} ${FFLAGS}\3!" \
${WRKSRC}/bin/sceptre
-post-install:
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/install.pdf ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc ; ${INSTALL_DATA} ${PORTDOCS:Mdoc_*} ${STAGEDIR}${DOCSDIR}
-.if !defined(BATCH)
-check test: install
- cd ${WRKSRC}/samples; for s in ${WRKSRC}/samples/*.d ; \
- do ${WRKSRC}/bin/sceptre $${s%.d} ; done
-.endif
+do-test:
+ cd ${WRKSRC}/samples; for s in ${WRKSRC}/samples/*.d; do \
+ ${WRKSRC}/bin/sceptre $${s%.d}; \
+ done
.include <bsd.port.mk>