aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authored <ed@FreeBSD.org>2010-06-28 17:07:31 +0800
committered <ed@FreeBSD.org>2010-06-28 17:07:31 +0800
commitf6574bd9a47108785601fff9a97b5d8ac90799f3 (patch)
tree0eb39f4312ba51b896108e16b0dfdadc4abbc0f4 /cad
parent4683b72009504fdceb42b1929346a84acaaa4254 (diff)
downloadfreebsd-ports-gnome-f6574bd9a47108785601fff9a97b5d8ac90799f3.tar.gz
freebsd-ports-gnome-f6574bd9a47108785601fff9a97b5d8ac90799f3.tar.zst
freebsd-ports-gnome-f6574bd9a47108785601fff9a97b5d8ac90799f3.zip
Remove a piece of dead code from chipmunk.
This seems to be the only piece of code in the entire ports tree which uses getpw(3) and it seems to be dead code anyway. Approved by: beat Feature safe: yes
Diffstat (limited to 'cad')
-rw-r--r--cad/chipmunk/Makefile2
-rw-r--r--cad/chipmunk/files/patch-netcmp-main.c19
2 files changed, 20 insertions, 1 deletions
diff --git a/cad/chipmunk/Makefile b/cad/chipmunk/Makefile
index 7d14ce300ee2..8f298e5c647f 100644
--- a/cad/chipmunk/Makefile
+++ b/cad/chipmunk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= chipmunk
PORTVERSION= 5.64
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= cad
MASTER_SITES= http://www.cs.berkeley.edu/~lazzaro/chipmunk/pickup/sources/
DISTFILES= psys-1.59.tar.gz log-5.64.tar.gz netcmp-1.13.tar.gz \
diff --git a/cad/chipmunk/files/patch-netcmp-main.c b/cad/chipmunk/files/patch-netcmp-main.c
new file mode 100644
index 000000000000..cb7c66aa3875
--- /dev/null
+++ b/cad/chipmunk/files/patch-netcmp-main.c
@@ -0,0 +1,19 @@
+--- netcmp/main.c
++++ netcmp/main.c
+@@ -122,16 +122,6 @@
+
+ outfyle = NULL;
+ while (outfyle == NULL) {
+- char username[100];
+- char *tmp;
+-
+-#if defined(freebsd)
+- getpwuid(getuid(), username);
+-#else
+- getpw(getuid(), username);
+-#endif
+- tmp = strchr(username,':');
+- if (tmp != NULL) *tmp = '\0';
+ printf(" Enter output file name [info]: ");
+ fgets(command, 81, stdin);
+ TEMP = strchr(command, '\n');