aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-08-08 09:28:03 +0800
committerwg <wg@FreeBSD.org>2014-08-08 09:28:03 +0800
commit03e5808e1d3aa26a282e0925be6b251f95f2909f (patch)
treef01b0ee441b95376017fc31a81ba2edd8d8ea444 /cad
parent91c54e717a046fbd56655110bcc960c0cdd332e1 (diff)
downloadfreebsd-ports-gnome-03e5808e1d3aa26a282e0925be6b251f95f2909f.tar.gz
freebsd-ports-gnome-03e5808e1d3aa26a282e0925be6b251f95f2909f.tar.zst
freebsd-ports-gnome-03e5808e1d3aa26a282e0925be6b251f95f2909f.zip
cad/cura-engine: Engine of slicing solution for RepRap 3D printers
The CuraEngine is a C++ console application for 3D printing GCode generation. It has been made as better and faster alternative to the old Skeinforge engine. The CuraEngine is pure C++ and uses Clipper from http://www.angusj.com/delphi/clipper.php. There are no external dependences and Clipper is included in the source code without modifications. This is just a console application for GCode generation. For a full graphical application look at https://github.com/daid/Cura with is the graphical frontend for CuraEngine. The CuraEngine can be used seperately or in other applications. Feel free to add it to your application. But to take note of the License. WWW: http://wiki.ultimaker.com/Cura PR: 192486 Submitted by: cederom tlen pl
Diffstat (limited to 'cad')
-rw-r--r--cad/Makefile1
-rw-r--r--cad/cura-engine/Makefile22
-rw-r--r--cad/cura-engine/distinfo2
-rw-r--r--cad/cura-engine/pkg-descr15
-rw-r--r--cad/cura-engine/pkg-plist2
5 files changed, 42 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index f4b92fca0b4a..18637fdba3f2 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -16,6 +16,7 @@
SUBDIR += cascade
SUBDIR += chipvault
SUBDIR += cider
+ SUBDIR += cura-engine
SUBDIR += dinotrace
SUBDIR += dxf2fig
SUBDIR += electric
diff --git a/cad/cura-engine/Makefile b/cad/cura-engine/Makefile
new file mode 100644
index 000000000000..c10324b43f9e
--- /dev/null
+++ b/cad/cura-engine/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= CuraEngine
+PORTVERSION= 14.03
+CATEGORIES= cad
+
+MAINTAINER= cederom@tlen.pl
+COMMENT= Engine of slicing solution for RepRap 3D printers
+
+LICENSE= AGPLv3
+
+USES= gmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= Ultimaker
+GH_COMMIT= 4c1043f
+GH_TAGNAME= ${GH_COMMIT}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/CuraEngine ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/cad/cura-engine/distinfo b/cad/cura-engine/distinfo
new file mode 100644
index 000000000000..59b933b6094f
--- /dev/null
+++ b/cad/cura-engine/distinfo
@@ -0,0 +1,2 @@
+SHA256 (CuraEngine-14.03.tar.gz) = a3966a2da3726b67e74007455e77c40c464d6b5a8d653065592bb88651c0b77d
+SIZE (CuraEngine-14.03.tar.gz) = 106704
diff --git a/cad/cura-engine/pkg-descr b/cad/cura-engine/pkg-descr
new file mode 100644
index 000000000000..6fbeda45b503
--- /dev/null
+++ b/cad/cura-engine/pkg-descr
@@ -0,0 +1,15 @@
+The CuraEngine is a C++ console application for 3D printing GCode generation.
+It has been made as better and faster alternative to the old Skeinforge engine.
+
+The CuraEngine is pure C++ and uses Clipper from
+http://www.angusj.com/delphi/clipper.php. There are no external dependences
+and Clipper is included in the source code without modifications.
+
+This is just a console application for GCode generation. For a full graphical
+application look at https://github.com/daid/Cura with is the graphical
+frontend for CuraEngine.
+
+The CuraEngine can be used seperately or in other applications.
+Feel free to add it to your application. But to take note of the License.
+
+WWW: http://wiki.ultimaker.com/Cura
diff --git a/cad/cura-engine/pkg-plist b/cad/cura-engine/pkg-plist
new file mode 100644
index 000000000000..980d32039741
--- /dev/null
+++ b/cad/cura-engine/pkg-plist
@@ -0,0 +1,2 @@
+bin/CuraEngine
+