aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-07-03 22:45:40 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-07-03 22:45:40 +0800
commit1df1f0fceb8594671aa80477d4aa7e3f0924079b (patch)
tree96da00e70af8ba143166d7da14b343b7a827178a /cad
parent959095a7ffbae4557385bef7ad2163ace9e0e27b (diff)
downloadfreebsd-ports-gnome-1df1f0fceb8594671aa80477d4aa7e3f0924079b.tar.gz
freebsd-ports-gnome-1df1f0fceb8594671aa80477d4aa7e3f0924079b.tar.zst
freebsd-ports-gnome-1df1f0fceb8594671aa80477d4aa7e3f0924079b.zip
In April/May 2012, STEP Class Library was renamed to STEPcode. This was done
because the old name wasn't accurate - the class libraries are only a fraction of the software. The STEP Class Library (SCL) originated at the National Institute of Standards and Technology, or NIST. NIST started working with STEP in the 80's and continued until the late 90's. Some components of SCL were originally written in Lisp and then re-written in mixed C and C++ in the early 90's. The rest of SCL was written in C++ to begin with. STEPcode (SC) includes the class libraries, some of the most widely used EXPRESS schemas, some tools to work with EXPRESS, and support libraries for those tools. Two of the tools can create schema-specific libraries that are used with the class libraries. There are also some test files and programs. WWW: https://github.com/stepcode/stepcode/wiki PR: 201046 Submitted by: fernando.apesteguia@gmail.com
Diffstat (limited to 'cad')
-rw-r--r--cad/Makefile1
-rw-r--r--cad/stepcode/Makefile28
-rw-r--r--cad/stepcode/distinfo2
-rw-r--r--cad/stepcode/pkg-descr16
-rw-r--r--cad/stepcode/pkg-plist118
5 files changed, 165 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index 9f2537cf95e0..7df088aaee3f 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -83,6 +83,7 @@
SUBDIR += scotch
SUBDIR += slffea
SUBDIR += spice
+ SUBDIR += stepcode
SUBDIR += sweethome3d
SUBDIR += tkgate
SUBDIR += tochnog
diff --git a/cad/stepcode/Makefile b/cad/stepcode/Makefile
new file mode 100644
index 000000000000..23fb6c134433
--- /dev/null
+++ b/cad/stepcode/Makefile
@@ -0,0 +1,28 @@
+# Created by: Fernando Apesteguia <fernando.apesteguia@gmail.com>
+# $FreeBSD$
+
+PORTNAME= stepcode
+PORTVERSION= 0.8
+DISTVERSIONPREFIX= v
+CATEGORIES= cad
+
+MAINTAINER= fernando.apesteguia@gmail.com
+COMMENT= Generates C++ and Python from ISO10303 files
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GITHUB= yes
+
+USE_LDCONFIG= yes
+
+USES= cmake:outsource compiler:c++11-lang
+CMAKE_ARGS+= -DSC_INSTALL_PREFIX=${PREFIX} \
+ -DSC_BUILD_TYPE=Release
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/schema_scanner
+ @(cd ${STAGEDIR}${PREFIX} ; \
+ ${FIND} include \( -type f -or -type l \) | ${SORT} >> ${TMPPLIST})
+
+.include <bsd.port.mk>
diff --git a/cad/stepcode/distinfo b/cad/stepcode/distinfo
new file mode 100644
index 000000000000..4400fbd16c26
--- /dev/null
+++ b/cad/stepcode/distinfo
@@ -0,0 +1,2 @@
+SHA256 (stepcode-stepcode-v0.8_GH0.tar.gz) = f9cc8a5a4193f97add595c1909433154f82983b892c532be2a696758b153fd2c
+SIZE (stepcode-stepcode-v0.8_GH0.tar.gz) = 5967472
diff --git a/cad/stepcode/pkg-descr b/cad/stepcode/pkg-descr
new file mode 100644
index 000000000000..3e7606bab56c
--- /dev/null
+++ b/cad/stepcode/pkg-descr
@@ -0,0 +1,16 @@
+In April/May 2012, STEP Class Library was renamed to STEPcode. This was done
+because the old name wasn't accurate - the class libraries are only a fraction
+of the software.
+
+The STEP Class Library (SCL) originated at the National Institute of Standards
+and Technology, or NIST. NIST started working with STEP in the 80's and
+continued until the late 90's. Some components of SCL were originally written
+in Lisp and then re-written in mixed C and C++ in the early 90's.
+The rest of SCL was written in C++ to begin with.
+
+STEPcode (SC) includes the class libraries, some of the most widely used EXPRESS
+schemas, some tools to work with EXPRESS, and support libraries for those tools.
+Two of the tools can create schema-specific libraries that are used with the
+class libraries. There are also some test files and programs.
+
+WWW: https://github.com/stepcode/stepcode/wiki
diff --git a/cad/stepcode/pkg-plist b/cad/stepcode/pkg-plist
new file mode 100644
index 000000000000..7f955f6852af
--- /dev/null
+++ b/cad/stepcode/pkg-plist
@@ -0,0 +1,118 @@
+bin/check-express
+bin/exp2cxx
+bin/exp2python
+bin/exppp
+bin/lazy_sdai_IFC4
+bin/lazy_sdai_ISO15926
+bin/lazy_sdai_ap203
+bin/lazy_sdai_ap203e2
+bin/lazy_sdai_ap210e2
+bin/lazy_sdai_ap214e3
+bin/lazy_sdai_ap219
+bin/lazy_sdai_ap227
+bin/lazy_sdai_ap235
+bin/lazy_sdai_ap238
+bin/lazy_sdai_ap239
+bin/lazy_sdai_ap240
+bin/lazy_sdai_cd209
+bin/lazy_sdai_cd242
+bin/lazy_sdai_ifc2x3
+bin/lazy_sdai_pdm
+bin/lazy_sdai_wip210e3
+bin/lazy_test
+bin/p21read_sdai_IFC4
+bin/p21read_sdai_ISO15926
+bin/p21read_sdai_ap203
+bin/p21read_sdai_ap203e2
+bin/p21read_sdai_ap210e2
+bin/p21read_sdai_ap214e3
+bin/p21read_sdai_ap219
+bin/p21read_sdai_ap227
+bin/p21read_sdai_ap235
+bin/p21read_sdai_ap238
+bin/p21read_sdai_ap239
+bin/p21read_sdai_ap240
+bin/p21read_sdai_cd209
+bin/p21read_sdai_cd242
+bin/p21read_sdai_ifc2x3
+bin/p21read_sdai_pdm
+bin/p21read_sdai_wip210e3
+bin/schema_scanner
+@comment include/* is handled dynamically in the Makefile
+lib/libbase.so
+lib/libbase.so.2
+lib/libbase.so.2.0.0
+lib/libexppp.so
+lib/libexppp.so.2
+lib/libexppp.so.2.0.0
+lib/libexpress.so
+lib/libexpress.so.2
+lib/libexpress.so.2.0.0
+lib/libsdai_IFC4.so
+lib/libsdai_IFC4.so.2
+lib/libsdai_IFC4.so.2.0.0
+lib/libsdai_ISO15926.so
+lib/libsdai_ISO15926.so.2
+lib/libsdai_ISO15926.so.2.0.0
+lib/libsdai_ap203.so
+lib/libsdai_ap203.so.2
+lib/libsdai_ap203.so.2.0.0
+lib/libsdai_ap203e2.so
+lib/libsdai_ap203e2.so.2
+lib/libsdai_ap203e2.so.2.0.0
+lib/libsdai_ap210e2.so
+lib/libsdai_ap210e2.so.2
+lib/libsdai_ap210e2.so.2.0.0
+lib/libsdai_ap214e3.so
+lib/libsdai_ap214e3.so.2
+lib/libsdai_ap214e3.so.2.0.0
+lib/libsdai_ap219.so
+lib/libsdai_ap219.so.2
+lib/libsdai_ap219.so.2.0.0
+lib/libsdai_ap227.so
+lib/libsdai_ap227.so.2
+lib/libsdai_ap227.so.2.0.0
+lib/libsdai_ap235.so
+lib/libsdai_ap235.so.2
+lib/libsdai_ap235.so.2.0.0
+lib/libsdai_ap238.so
+lib/libsdai_ap238.so.2
+lib/libsdai_ap238.so.2.0.0
+lib/libsdai_ap239.so
+lib/libsdai_ap239.so.2
+lib/libsdai_ap239.so.2.0.0
+lib/libsdai_ap240.so
+lib/libsdai_ap240.so.2
+lib/libsdai_ap240.so.2.0.0
+lib/libsdai_cd209.so
+lib/libsdai_cd209.so.2
+lib/libsdai_cd209.so.2.0.0
+lib/libsdai_cd242.so
+lib/libsdai_cd242.so.2
+lib/libsdai_cd242.so.2.0.0
+lib/libsdai_ifc2x3.so
+lib/libsdai_ifc2x3.so.2
+lib/libsdai_ifc2x3.so.2.0.0
+lib/libsdai_pdm.so
+lib/libsdai_pdm.so.2
+lib/libsdai_pdm.so.2.0.0
+lib/libsdai_wip210e3.so
+lib/libsdai_wip210e3.so.2
+lib/libsdai_wip210e3.so.2.0.0
+lib/libstepcore.so
+lib/libstepcore.so.2
+lib/libstepcore.so.2.0.0
+lib/libstepdai.so
+lib/libstepdai.so.2
+lib/libstepdai.so.2.0.0
+lib/libstepeditor.so
+lib/libstepeditor.so.2
+lib/libstepeditor.so.2.0.0
+lib/libsteplazyfile.so
+lib/libsteplazyfile.so.2
+lib/libsteplazyfile.so.2.0.0
+lib/libsteputils.so
+lib/libsteputils.so.2
+lib/libsteputils.so.2.0.0
+share/man/man1/exp2cxx.1
+share/man/man1/fedex.1