aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-02-04 06:19:54 +0800
committerthierry <thierry@FreeBSD.org>2006-02-04 06:19:54 +0800
commit3035323da64f04a75b76324037b98add711d3254 (patch)
treec452e47bd040218c904f4b45d94e31aac85fa5ff /cad
parente661e9c2df29a68bfe7f6fba07bf58d8fe61fc19 (diff)
downloadfreebsd-ports-gnome-3035323da64f04a75b76324037b98add711d3254.tar.gz
freebsd-ports-gnome-3035323da64f04a75b76324037b98add711d3254.tar.zst
freebsd-ports-gnome-3035323da64f04a75b76324037b98add711d3254.zip
SCOTCH is a software package and libraries for graph, mesh and hypergraph
partitioning, static mapping, and sparse matrix block ordering. Its purpose of Scotch is to apply graph theory, with a divide and conquer approach, to scientific computing problems such as graph and mesh partitioning, static mapping, and sparse matrix ordering, in application domains ranging from structural mechanics to operating systems or bio-chemistry. Note: there is an older tarball included in Aster's distfile, but I prefer a separate distfile from the official site.
Diffstat (limited to 'cad')
-rw-r--r--cad/Makefile1
-rw-r--r--cad/scotch/Makefile71
-rw-r--r--cad/scotch/distinfo3
-rw-r--r--cad/scotch/files/patch-src_Make.inc_Makefile.inc.FreeBSD18
-rw-r--r--cad/scotch/pkg-descr13
-rw-r--r--cad/scotch/pkg-plist114
6 files changed, 220 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index 0ea7c9abed2c..9b895a5ca1c5 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -52,6 +52,7 @@
SUBDIR += qmls
SUBDIR += qucs
SUBDIR += sceptre
+ SUBDIR += scotch
SUBDIR += slffea
SUBDIR += spice
SUBDIR += systemc
diff --git a/cad/scotch/Makefile b/cad/scotch/Makefile
new file mode 100644
index 000000000000..454201a7b989
--- /dev/null
+++ b/cad/scotch/Makefile
@@ -0,0 +1,71 @@
+# New ports collection makefile for: scotch
+# Date created: Thu 2 feb 2006
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= scotch
+PORTVERSION= 4.0.0
+CATEGORIES= cad science
+MASTER_SITES= http://gforge.inria.fr/frs/download.php/453/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= A package for graph and mesh partitioning and sparse matrix ordering
+
+USE_GMAKE= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME:R}
+BUILD_WRKSRC= ${WRKSRC}/src
+INSTALL_WRKSRC= ${WRKSRC}/bin
+
+F77?= f77
+
+BINS= acpl amk_ccc amk_fft2 amk_grf amk_hy amk_m2 amk_p2 atst \
+ gcv gmap gmk_hy gmk_m2 gmk_m3 gmk_msh gmk_ub2 gmtst gord\
+ gotst gout gtst mcv mmk_m2 mmk_m3 mord mtst
+INCS= common.h common_integer.h scotch.h scotchf.h
+LIBS= libcommon.a libscotch.a libscotcherr.a libscotcherrcom.a
+PORTDOCS= scotch_user4.0.pdf
+EXAMPLES= scotch_example.f
+
+MALLOC2FIX= common/common.h libscotch/common.h
+
+post-extract:
+ ${CP} -p ${BUILD_WRKSRC}/Make.inc/Makefile.inc.i686_pc_linux2 \
+ ${BUILD_WRKSRC}/Make.inc/Makefile.inc.FreeBSD
+
+pre-configure:
+ ${LN} -sf ${WRKSRC}/src/Make.inc/Makefile.inc.FreeBSD \
+ ${WRKSRC}/src/Makefile.inc
+ ${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' \
+ ${MALLOC2FIX:S|^|${BUILD_WRKSRC}/|}
+ ${REINPLACE_CMD} -e 's|make|${GMAKE}|g' ${BUILD_WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${BINS:S|^|${INSTALL_WRKSRC}/|} ${PREFIX}/bin
+ ${INSTALL_DATA} ${INCS:S|^|${INSTALL_WRKSRC}/|} ${PREFIX}/include
+ ${INSTALL_DATA} ${LIBS:S|^|${INSTALL_WRKSRC}/|} ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}/grf ${EXAMPLESDIR}/tgt
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ ${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/doc/|} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/grf/* ${EXAMPLESDIR}/grf
+ ${INSTALL_DATA} ${WRKSRC}/tgt/* ${EXAMPLESDIR}/tgt
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
+.if defined(MAINTAINER_MODE)
+test: install
+ (amk_ccc 3 | acpl - ${WRKDIR}/ccc3.tgt && \
+ ${GUNZIP_CMD} -c ${EXAMPLESDIR}/grf/bump.grf.gz | \
+ gmap - ${WRKDIR}/ccc3.tgt ${WRKDIR}/brol.map)
+ (cd ${WRKSRC}/doc && \
+ ${F77} -o scotch_test scotch_example.f \
+ -I${PREFIX}/include -L${PREFIX}/lib -lscotch -lscotcherr -lm \
+ && ./scotch_test)
+.endif
+
+.include <bsd.port.mk>
diff --git a/cad/scotch/distinfo b/cad/scotch/distinfo
new file mode 100644
index 000000000000..d9ccf3fbd19c
--- /dev/null
+++ b/cad/scotch/distinfo
@@ -0,0 +1,3 @@
+MD5 (scotch_4.0.0.tar.gz) = f1fb5b453f5df20c7b29c30817d584e0
+SHA256 (scotch_4.0.0.tar.gz) = ac9fafdf5ee51a139f707b8948199cb9abed17dcd4148c92462bbc7b878bcb95
+SIZE (scotch_4.0.0.tar.gz) = 2534197
diff --git a/cad/scotch/files/patch-src_Make.inc_Makefile.inc.FreeBSD b/cad/scotch/files/patch-src_Make.inc_Makefile.inc.FreeBSD
new file mode 100644
index 000000000000..ff75b777ab33
--- /dev/null
+++ b/cad/scotch/files/patch-src_Make.inc_Makefile.inc.FreeBSD
@@ -0,0 +1,18 @@
+--- ./src/Make.inc/Makefile.inc.FreeBSD.orig Tue Jan 31 17:15:20 2006
++++ ./src/Make.inc/Makefile.inc.FreeBSD Thu Feb 2 21:34:48 2006
+@@ -4,11 +4,11 @@
+
+ AR = ar
+ CAT = cat
+-CC = gcc
+-CFLAGS = -O3 -I. -I../../bin -DCOMMON_RANDOM_FIXED_SEED -DSCOTCH_RENAME
+-LDFLAGS = -L../../bin -lm
++#CC = gcc
++CFLAGS += -I. -I../../bin -DCOMMON_RANDOM_FIXED_SEED -DSCOTCH_RENAME
++LDFLAGS+= -L../../bin -lm
+ CP = cp
+ LEX = flex
+ MV = mv
+ RANLIB = ranlib
+-YACC = bison -y
++#YACC = bison -y
diff --git a/cad/scotch/pkg-descr b/cad/scotch/pkg-descr
new file mode 100644
index 000000000000..d80e828f5920
--- /dev/null
+++ b/cad/scotch/pkg-descr
@@ -0,0 +1,13 @@
+SCOTCH is a software package and libraries for graph, mesh and hypergraph
+partitioning, static mapping, and sparse matrix block ordering.
+
+Its purpose of Scotch is to apply graph theory, with a divide and conquer
+approach, to scientific computing problems such as graph and mesh partitioning,
+static mapping, and sparse matrix ordering, in application domains ranging from
+structural mechanics to operating systems or bio-chemistry.
+
+The SCOTCH distribution is a set of programs and libraries which implement the
+static mapping and sparse matrix reordering algorithms developed within the
+SCOTCH project.
+
+WWW: http://www.labri.fr/perso/pelegrin/scotch/
diff --git a/cad/scotch/pkg-plist b/cad/scotch/pkg-plist
new file mode 100644
index 000000000000..635ca4ade04c
--- /dev/null
+++ b/cad/scotch/pkg-plist
@@ -0,0 +1,114 @@
+bin/acpl
+bin/amk_ccc
+bin/amk_fft2
+bin/amk_grf
+bin/amk_hy
+bin/amk_m2
+bin/amk_p2
+bin/atst
+bin/gcv
+bin/gmap
+bin/gmk_hy
+bin/gmk_m2
+bin/gmk_m3
+bin/gmk_msh
+bin/gmk_ub2
+bin/gmtst
+bin/gord
+bin/gotst
+bin/gout
+bin/gtst
+bin/mcv
+bin/mmk_m2
+bin/mmk_m3
+bin/mord
+bin/mtst
+include/common.h
+include/common_integer.h
+include/scotch.h
+include/scotchf.h
+lib/libcommon.a
+lib/libscotch.a
+lib/libscotcherr.a
+lib/libscotcherrcom.a
+%%PORTDOCS%%%%EXAMPLESDIR%%/grf/3elt.grf.gz
+%%PORTDOCS%%%%EXAMPLESDIR%%/grf/3elt.xyz.gz
+%%PORTDOCS%%%%EXAMPLESDIR%%/grf/4elt.grf.gz
+%%PORTDOCS%%%%EXAMPLESDIR%%/grf/4elt.xyz.gz
+%%PORTDOCS%%%%EXAMPLESDIR%%/grf/4elt2.grf.gz
+%%PORTDOCS%%%%EXAMPLESDIR%%/grf/4elt2.xyz.gz
+%%PORTDOCS%%%%EXAMPLESDIR%%/grf/bump.grf.gz
+%%PORTDOCS%%%%EXAMPLESDIR%%/grf/bump.xyz.gz
+%%PORTDOCS%%%%EXAMPLESDIR%%/scotch_example.f
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/SP2_16.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/T3D_64.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/h1.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/h10.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/h2.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/h3.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/h4.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/h5.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/h6.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/h7.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/h8.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/h9.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k1.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k12.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k128.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k16.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k2.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k24.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k256.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k32.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k4.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k48.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k512.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k6.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k64.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k7.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k8.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/k96.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m10x10.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m10x20.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m11x13.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m16x16.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m16x32.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m17x19.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m19x21.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m19x31.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m21x23.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m23x25.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m24x24.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m25x27.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m27x29.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m29x31.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m2x2.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m2x4x8.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m32x32.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m3x3.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m4x4.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m4x8.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m5x5.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m5x7.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m64x64.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m8x16.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m8x8.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m9x11.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/m9x7.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/p128.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/p16.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/p2.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/p256.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/p32.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/p4.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/p512.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/p64.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/p8.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/t2x4x8.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/t4x4x4.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/vcmplt.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/vhcub.tgt
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgt/void.tgt
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/tgt
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/grf
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%