aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2013-05-25 22:37:02 +0800
committerzeising <zeising@FreeBSD.org>2013-05-25 22:37:02 +0800
commit715298b528f23a6a763e28623a4c98f1365c81ce (patch)
treecf13f962932aab3646f0af684b2923c4e0f0825b /cad
parent0f8e632e50d273ba38d9d13f7e446a4a10d95cd4 (diff)
downloadfreebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.tar.gz
freebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.tar.zst
freebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.zip
The FreeBSD x11 team proudly presents
an zeising, kwm, miwi, bapt, eadler production: Xorg 7.7 Starring: xserver 1.12.4 (new xorg only) Mesa 8.0.4, including libGL, libGLU and dri (new xorg only) libX11 1.5.0 libxcb 1.9 libdrm 2.4.42 (new xorg only) freeglut 2.8.1 Also starring: Updates to drivers and other libraries and utilities Additional notes: Change pkgconf to be a build dependency. Add a new USE_XORG, xcb, to depend on libxcb and update all ports to use this. Trim makefile headers. Take maintanership of x11/xcb-proto, ok'd by ashish. If you are running WITH_NEW_XORG=, you need to rebuild all installed drivers, see UPDATING for more information. Various fixes to make ports compile. PR: ports/177942 Exp-run by: miwi Approved by: portmgr (miwi) Thanks to all who helped testing!
Diffstat (limited to 'cad')
-rw-r--r--cad/brlcad/Makefile5
-rw-r--r--cad/openvsp/Makefile5
-rw-r--r--cad/pdnmesh/Makefile7
-rw-r--r--cad/repsnapper/Makefile7
4 files changed, 10 insertions, 14 deletions
diff --git a/cad/brlcad/Makefile b/cad/brlcad/Makefile
index 6321ae53b6eb..3327c7c33196 100644
--- a/cad/brlcad/Makefile
+++ b/cad/brlcad/Makefile
@@ -18,12 +18,11 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
rle:${PORTSDIR}/graphics/urt \
freetype:${PORTSDIR}/print/freetype2 \
expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- xcb:${PORTSDIR}/x11/libxcb
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
USE_BZIP2= yes
USE_GL= gl glu
-USE_XORG= ice inputproto sm x11 xau xdamage xdmcp xext xfixes xft xi \
+USE_XORG= ice inputproto sm x11 xau xcb xdamage xdmcp xext xfixes xft xi \
xproto xrender xscrnsaver xt xxf86vm
USE_GMAKE= yes
USES= bison pathfix cmake
diff --git a/cad/openvsp/Makefile b/cad/openvsp/Makefile
index 3cb4c3b35fca..bfe69884283a 100644
--- a/cad/openvsp/Makefile
+++ b/cad/openvsp/Makefile
@@ -16,8 +16,7 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
freetype:${PORTSDIR}/print/freetype2 \
expat:${PORTSDIR}/textproc/expat2 \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- fltk:${PORTSDIR}/x11-toolkits/fltk \
- xcb:${PORTSDIR}/x11/libxcb
+ fltk:${PORTSDIR}/x11-toolkits/fltk
USE_GITHUB= yes
GH_PROJECT= OpenVSP
@@ -28,7 +27,7 @@ GH_COMMIT= fb52aa2
CMAKE_SOURCE_PATH= ${WRKSRC}/src
USES= cmake:outsource iconv
USE_DOS2UNIX= yes
-USE_XORG= ice sm x11 xau xdamage xdmcp xext xfixes xft \
+USE_XORG= ice sm x11 xau xcb xdamage xdmcp xext xfixes xft \
xinerama xrender xxf86vm
USE_GL= glu
USE_GNOME= libxml2
diff --git a/cad/pdnmesh/Makefile b/cad/pdnmesh/Makefile
index 347f79096442..393d24161083 100644
--- a/cad/pdnmesh/Makefile
+++ b/cad/pdnmesh/Makefile
@@ -20,8 +20,7 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
freetype:${PORTSDIR}/print/freetype2 \
expat:${PORTSDIR}/textproc/expat2 \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- gtkglext:${PORTSDIR}/x11-toolkits/gtkglext \
- xcb:${PORTSDIR}/x11/libxcb
+ gtkglext:${PORTSDIR}/x11-toolkits/gtkglext
OPTIONS_DEFINE= ATLAS DOCS EXAMPLES
ATLAS_DESC= Enable ATLAS support
@@ -30,8 +29,8 @@ USES= pkgconfig gettext iconv
USE_FORTRAN= yes
USE_GL= glu
USE_GNOME= gdkpixbuf2 gtk20
-USE_XORG= ice pixman sm x11 xau xcomposite xcursor xdamage xdmcp xext \
- xfixes xmu xi xinerama xrandr xrender xt xxf86vm
+USE_XORG= ice pixman sm x11 xau xcb xcomposite xcursor xdamage xdmcp \
+ xext xfixes xmu xi xinerama xrandr xrender xt xxf86vm
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/cad/repsnapper/Makefile b/cad/repsnapper/Makefile
index 17b53416521a..db15d22235da 100644
--- a/cad/repsnapper/Makefile
+++ b/cad/repsnapper/Makefile
@@ -32,8 +32,7 @@ LIB_DEPENDS= gtkglext:${PORTSDIR}/x11-toolkits/gtkglext \
expat:${PORTSDIR}/textproc/expat2 \
xml++-2.6:${PORTSDIR}/textproc/libxml++26 \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- pangomm-1.4:${PORTSDIR}/x11-toolkits/pangomm \
- xcb:${PORTSDIR}/x11/libxcb
+ pangomm-1.4:${PORTSDIR}/x11-toolkits/pangomm
MAKE_JOBS_SAFE= yes
USES= pkgconfig iconv
@@ -41,8 +40,8 @@ USE_GNOME= gdkpixbuf2 gtk20 libxml2
USE_GL= glu glut
USE_AUTOTOOLS= automake libtool
USE_GMAKE= yes
-USE_XORG= ice pixman sm x11 xau xcomposite xcursor xdamage xdmcp xext \
- xfixes xi xinerama xmu xrandr xrender xt xxf86vm
+USE_XORG= ice pixman sm x11 xau xcb composite xcursor xdamage xdmcp \
+ xext xfixes xi xinerama xmu xrandr xrender xt xxf86vm
.include <bsd.port.options.mk>