aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2017-08-02 23:40:46 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:17:12 +0800
commit8d8c67f2923615171ace205a4dc17dce761df2e9 (patch)
tree0cbcaeb8628a60e19da380e7346474984e60df3a /cad
parent4cf76bac0839c0f7b77e089482342f9a72bf36d9 (diff)
downloadfreebsd-ports-gnome-8d8c67f2923615171ace205a4dc17dce761df2e9.tar.gz
freebsd-ports-gnome-8d8c67f2923615171ace205a4dc17dce761df2e9.tar.zst
freebsd-ports-gnome-8d8c67f2923615171ace205a4dc17dce761df2e9.zip
Explicitly build with -std=gnu++03.
GCC 6 changed its default from -std=gnu++03 to -std=gnu++14, and this port's code is not compatible with C++11. Since the project looks abandoned upstream, it makes more sense to just continue building with an older C++ standard. PR: 219297 Approved by: portmgr (blanket approval)
Diffstat (limited to 'cad')
-rw-r--r--cad/freehdl/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/cad/freehdl/Makefile b/cad/freehdl/Makefile
index 93754b3efd21..71acf082050c 100644
--- a/cad/freehdl/Makefile
+++ b/cad/freehdl/Makefile
@@ -17,6 +17,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= SYSTEM_LIBTOOL=${FALSE}
INSTALL_TARGET= install-strip
+# Bug 219297: GCC 6 changed its default from -std=gnu++03 to -std=gnu++14, and
+# this port's code is not compatible with C++11. Since the project looks
+# abandoned upstream, it makes more sense to just continue building with an
+# older C++ standard.
+USE_CXXSTD= gnu++03
+
INFO= fire
.include <bsd.port.mk>