aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-02-07 18:06:42 +0800
committergerald <gerald@FreeBSD.org>2009-02-07 18:06:42 +0800
commit60819d7d2dd3c3de2458d93f99af5ac1872a7314 (patch)
tree079408a1303ff93a44a0c6113a41a0eaefc4e037 /cad
parentaaf8fd35f8384853e39b487d81c7fd0fd1a08470 (diff)
downloadfreebsd-ports-gnome-60819d7d2dd3c3de2458d93f99af5ac1872a7314.tar.gz
freebsd-ports-gnome-60819d7d2dd3c3de2458d93f99af5ac1872a7314.tar.zst
freebsd-ports-gnome-60819d7d2dd3c3de2458d93f99af5ac1872a7314.zip
Pacify portlint by using a tab instead of spaces after variable
names and no longer passing FC, F77, and FFLAGS to CONFIGURE_ENV. Approved by: maintainer timeout (sarod@users.sf.net, 16 days)
Diffstat (limited to 'cad')
-rw-r--r--cad/pdnmesh/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/cad/pdnmesh/Makefile b/cad/pdnmesh/Makefile
index ef15da365a91..4a3a6f55eb4b 100644
--- a/cad/pdnmesh/Makefile
+++ b/cad/pdnmesh/Makefile
@@ -22,21 +22,21 @@ LIB_DEPENDS= gtkglext:${PORTSDIR}/x11-toolkits/gtkglext
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
-WITH_ATLAS= yes
+WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
BLAS= -lf77blas -latlas
LAPACK= -lalapack -lcblas
.else
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.endif
USE_FORTRAN= yes
-CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}" BLAS_LIBS="${BLAS}" LAPACK_LIBS="${LAPACK}"
+CONFIGURE_ENV+= BLAS_LIBS="${BLAS}" LAPACK_LIBS="${LAPACK}"
USE_GL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"