aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2016-05-17 01:47:10 +0800
committerhrs <hrs@FreeBSD.org>2016-05-17 01:47:10 +0800
commit670ce282b22a744d6eec060e545d54a3b3032d9b (patch)
treee5b524dd9b347149ed55c5af6549e3a8b92ec817 /cad
parentfe608729c127bbd997bd3aa67262ee482124c042 (diff)
downloadfreebsd-ports-gnome-670ce282b22a744d6eec060e545d54a3b3032d9b.tar.gz
freebsd-ports-gnome-670ce282b22a744d6eec060e545d54a3b3032d9b.tar.zst
freebsd-ports-gnome-670ce282b22a744d6eec060e545d54a3b3032d9b.zip
Update to 4.0.4.
Diffstat (limited to 'cad')
-rw-r--r--cad/gdt/Makefile14
-rw-r--r--cad/gdt/distinfo5
-rw-r--r--cad/gdt/files/patch-Examples-gdsinfo6
-rw-r--r--cad/gdt/files/patch-Examples-scalegds10
-rw-r--r--cad/gdt/files/patch-gdsStream.h6
5 files changed, 21 insertions, 20 deletions
diff --git a/cad/gdt/Makefile b/cad/gdt/Makefile
index 946450f526a8..23fa97f1eed6 100644
--- a/cad/gdt/Makefile
+++ b/cad/gdt/Makefile
@@ -1,9 +1,9 @@
# $FreeBSD$
PORTNAME= gdt
-PORTVERSION= 4.0
+PORTVERSION= 4.0.4
CATEGORIES= cad
-MASTER_SITES= SF/gds2/gds2/
+MASTER_SITES= SF/gds2
DISTNAME= ${PORTNAME:tu}-${PORTVERSION}
MAINTAINER= hrs@FreeBSD.org
@@ -11,7 +11,7 @@ COMMENT= GDS2/GDT format translator
LICENSE= GPLv2
-USES= shebangfix perl5
+USES= shebangfix perl5
USE_PERL5= run
SHEBANG_FILES= Examples/gdsinfo Examples/scalegds
WRKSRC= ${WRKDIR}/${PORTNAME:tu}-${PORTVERSION}
@@ -19,15 +19,15 @@ PLIST_FILES= bin/gdsinfo bin/gds2gdt bin/gdt2gds bin/scalegds
post-patch:
${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
- ${WRKSRC}/Examples/gdsinfo ${WRKSRC}/Examples/scalegds
+ ${WRKSRC}/Examples/gdsinfo ${WRKSRC}/Examples/scalegds
pre-build:
${INSTALL_DATA} ${FILESDIR}/Makefile ${WRKSRC}
post-install:
${INSTALL_SCRIPT} \
- ${WRKSRC}/Examples/gdsinfo \
- ${WRKSRC}/Examples/scalegds \
- ${STAGEDIR}${PREFIX}/bin
+ ${WRKSRC}/Examples/gdsinfo \
+ ${WRKSRC}/Examples/scalegds \
+ ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/cad/gdt/distinfo b/cad/gdt/distinfo
index b5699ef9e283..84af187371ee 100644
--- a/cad/gdt/distinfo
+++ b/cad/gdt/distinfo
@@ -1,2 +1,3 @@
-SHA256 (GDT-4.0.tar.gz) = 3c1247aa1a8044002edc5db10136a0c9befbf0f49f8c86643189051090ef5fcb
-SIZE (GDT-4.0.tar.gz) = 46937
+TIMESTAMP = 1463381718
+SHA256 (GDT-4.0.4.tar.gz) = 950bbab650d9a75eeaad3305bac90981b9f5765cd1bf00a8ba077e8321ac26cb
+SIZE (GDT-4.0.4.tar.gz) = 47755
diff --git a/cad/gdt/files/patch-Examples-gdsinfo b/cad/gdt/files/patch-Examples-gdsinfo
index 4c74eaee33cd..4a8aa20a2103 100644
--- a/cad/gdt/files/patch-Examples-gdsinfo
+++ b/cad/gdt/files/patch-Examples-gdsinfo
@@ -1,6 +1,6 @@
---- Examples/gdsinfo.orig 2008-06-20 02:04:27.000000000 +0900
-+++ Examples/gdsinfo 2013-05-30 10:54:47.000000000 +0900
-@@ -75,10 +75,7 @@
+--- Examples/gdsinfo.orig 2016-05-16 17:46:24 UTC
++++ Examples/gdsinfo
+@@ -75,10 +75,7 @@ $topCellNames =~ s/,/ /g;
$topCellNames =~ s/\s+/ /g;
# help find gds2gdt
diff --git a/cad/gdt/files/patch-Examples-scalegds b/cad/gdt/files/patch-Examples-scalegds
index 5a4b679acea7..fafea2c91cca 100644
--- a/cad/gdt/files/patch-Examples-scalegds
+++ b/cad/gdt/files/patch-Examples-scalegds
@@ -1,6 +1,6 @@
---- Examples/scalegds.orig 2013-05-30 10:59:09.000000000 +0900
-+++ Examples/scalegds 2013-05-30 10:58:01.000000000 +0900
-@@ -72,18 +72,14 @@
+--- Examples/scalegds.orig 2016-05-16 17:46:24 UTC
++++ Examples/scalegds
+@@ -72,18 +72,14 @@ unless ($color)
my ($sec,$min,$hour,$mday,$mon,$year,$wday,$yday,$isdst) = localtime(time);
$mon++; $year += 1900;
@@ -21,7 +21,7 @@
unless ($gdt2gds)
{
die $REVERSE_RED.ERROR."$COLOR_RESET unable to find gdt2gds in \$PATH";
-@@ -135,7 +131,7 @@
+@@ -135,7 +131,7 @@ my $fhJunk = new FileHandle; # not using
if ($inputFile =~ m/\.(gz|Z)$/)
{
@@ -30,7 +30,7 @@
unless ($zcat)
{
die $REVERSE_RED.ERROR."$COLOR_RESET unable to find zcat in \$PATH";
-@@ -145,7 +141,7 @@
+@@ -145,7 +141,7 @@ if ($inputFile =~ m/\.(gz|Z)$/)
}
elsif ($inputFile =~ m/\.bz2$/)
{
diff --git a/cad/gdt/files/patch-gdsStream.h b/cad/gdt/files/patch-gdsStream.h
index 00a5ade48a48..dc2f069981f8 100644
--- a/cad/gdt/files/patch-gdsStream.h
+++ b/cad/gdt/files/patch-gdsStream.h
@@ -1,6 +1,6 @@
---- gdsStream.h.orig Sun Apr 29 15:45:42 2007
-+++ gdsStream.h Sun Apr 29 15:45:54 2007
-@@ -3,8 +3,7 @@
+--- gdsStream.h.orig 2014-12-08 17:16:44 UTC
++++ gdsStream.h
+@@ -4,8 +4,7 @@
#define _gdsStream__
#include <stdio.h>