aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-09-10 03:42:46 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-09-10 03:42:46 +0800
commit6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7 (patch)
treeb3bdcd25b598432ef78aefb0f72e9412f429eee4 /cad
parentb236a9c0408bb4c5dd28e3128687a5de61161a27 (diff)
downloadfreebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.tar.gz
freebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.tar.zst
freebsd-ports-gnome-6e502d51f3f34690037f4f33bb5cf0f0f50e2ca7.zip
Most commonly used build systems support silent builds, when they
hide actual commands executed and only show short summary line (like "CC foo.c"). CMake and ninja enable this by default, some autotools using ports do as well. This is unacceptable because we need complete build logs at any time, so we now switch to verbose build logs unconditionally. Note that this change deliberately affects ALL builds and not only package builds on cluster, because we need to be sure that user experiencing failure can always provide informative build log regardless of settings and without rerunning the build. Change summary: - Always do verbose builds for cmake, ninja and GNU configure (the latter includes check if --disable-silent-rules is actually supported by the configure script; there are isolated cases when it's not true) - Remove CMAKE_VERBOSE, NINJA_VERBOSE and CONFIGURE_ARGS=--disable-silent-rules from all ports which set them for this is no longer needed - Revert hacks for --disable-silent-rules support priorly committed to biology/ncbi-blast+ and net-p2p/mldonkey - no longer needed as well Submitted by: amdmi3 Reviewed by: mat Exp-run by: antoine Approved by: portmgr (mat, antoine) Differential Revision: D7534
Diffstat (limited to 'cad')
-rw-r--r--cad/adms/Makefile1
-rw-r--r--cad/kicad-devel/Makefile1
2 files changed, 0 insertions, 2 deletions
diff --git a/cad/adms/Makefile b/cad/adms/Makefile
index be771f4d115e..739cef9c5e76 100644
--- a/cad/adms/Makefile
+++ b/cad/adms/Makefile
@@ -15,7 +15,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= bison libtool
GNU_CONFIGURE= yes
CONFIGURE_ENV= ax_cv_c_compiler_vendor=gnu
-CONFIGURE_ARGS= --disable-silent-rules
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index b164d7c7b56a..5f0462c9e0ea 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -42,7 +42,6 @@ USES= desktop-file-utils shared-mime-info compiler:c++11-lib tar:bzip2 cmake \
gettext python
CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}" \
- -DCMAKE_VERBOSE_MAKEFILE=ON \
-DCMAKE_BUILD_TYPE="Debug" \
-DKICAD_TESTING_VERSION=ON \
-DKICAD_BUILD_VERSION=${DISTVERSION} \