aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2007-04-29 15:17:29 +0800
committerhrs <hrs@FreeBSD.org>2007-04-29 15:17:29 +0800
commit4d4750d80c3628b8acac100e2cf78b649655bbb3 (patch)
tree879b4171a090a2dddecaef2cbe55042f8ab8616e /cad
parent193aeeb6bfab009d0207ea53057868ed30b8555d (diff)
downloadfreebsd-ports-gnome-4d4750d80c3628b8acac100e2cf78b649655bbb3.tar.gz
freebsd-ports-gnome-4d4750d80c3628b8acac100e2cf78b649655bbb3.tar.zst
freebsd-ports-gnome-4d4750d80c3628b8acac100e2cf78b649655bbb3.zip
p5-GDS2, a Perl module for quickly creating programs to read and/or
write GDS2 files.
Diffstat (limited to 'cad')
-rw-r--r--cad/Makefile1
-rw-r--r--cad/p5-GDS2/Makefile34
-rw-r--r--cad/p5-GDS2/distinfo3
-rw-r--r--cad/p5-GDS2/files/patch-lib-GDS2.pm.PL33
-rw-r--r--cad/p5-GDS2/pkg-descr2
5 files changed, 73 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index 2706002cd6ea..813346e113b7 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -57,6 +57,7 @@
SUBDIR += opencascade
SUBDIR += opencascade-tutorial
SUBDIR += oregano
+ SUBDIR += p5-GDS2
SUBDIR += pcb
SUBDIR += pdnmesh
SUBDIR += pythoncad
diff --git a/cad/p5-GDS2/Makefile b/cad/p5-GDS2/Makefile
new file mode 100644
index 000000000000..55e65ed4a3f4
--- /dev/null
+++ b/cad/p5-GDS2/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-GDS2
+# Date created: Sun, Apr 29 2007
+# Whom: Hiroki Sato <hrs@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GDS2
+PORTVERSION= 2.09.a
+CATEGORIES= cad perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= GDS2
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S,.a$,a,}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= GDS2 - GDS2 stream module
+
+USE_PERL5= yes
+PERL_MODBUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S,.a$,,}
+PLIST_FILES= ${SITE_PERL_REL}/GDS2.pm \
+ ${PROGRAMS:S,^,bin/,}
+
+MAN3= GDS2.3
+
+PROGRAMS= gdsdump2gds modgds2 gdslayers testgds2 \
+ gdspath4topath0 testgdt
+# XXX: gdsdump disabled for the moment
+
+post-install:
+ ${INSTALL_SCRIPT} ${PROGRAMS:S,^,${WRKSRC}/Examples/,} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/cad/p5-GDS2/distinfo b/cad/p5-GDS2/distinfo
new file mode 100644
index 000000000000..ca2af4eb86d9
--- /dev/null
+++ b/cad/p5-GDS2/distinfo
@@ -0,0 +1,3 @@
+MD5 (GDS2-2.09a.tar.gz) = 7406ebd77a064f46cd822b651db4332e
+SHA256 (GDS2-2.09a.tar.gz) = 7f38fc6eae1893eb641342b954411ed05a96ed53f6e82223a30190c9ffd0cb0e
+SIZE (GDS2-2.09a.tar.gz) = 51538
diff --git a/cad/p5-GDS2/files/patch-lib-GDS2.pm.PL b/cad/p5-GDS2/files/patch-lib-GDS2.pm.PL
new file mode 100644
index 000000000000..6f9b74ca4b8e
--- /dev/null
+++ b/cad/p5-GDS2/files/patch-lib-GDS2.pm.PL
@@ -0,0 +1,33 @@
+--- lib/GDS2.pm.PL.orig Thu May 12 13:19:30 2005
++++ lib/GDS2.pm.PL Sun Apr 29 15:08:31 2007
+@@ -11,19 +11,20 @@
+
+ EOP
+
+-print "Do you want to use Inline::C code? (y/N): ";
++#print "Do you want to use Inline::C code? (y/N): ";
+
+-my $response = <STDIN>;
+-if ($response =~ m/^[yY]/)
+-{
+- $response = 'yes';
+- print "\nMaking version of GDS2.pm with C code on....";
+-}
+-else
+-{
++#my $response = <STDIN>;
++my $response;
++#if ($response =~ m/^[yY]/)
++#{
++# $response = 'yes';
++# print "\nMaking version of GDS2.pm with C code on....";
++#}
++#else
++#{
+ $response = 'no';
+ print "\nMaking version of GDS2.pm with C code off....";
+-}
++#}
+
+ rename "lib/GDS2.pm","lib/GDS2.pm.original";
+ open(OLD,"<lib/GDS2.pm.original") or die "Unable to read lib/GDS2.pm.original $!";
diff --git a/cad/p5-GDS2/pkg-descr b/cad/p5-GDS2/pkg-descr
new file mode 100644
index 000000000000..89300626423c
--- /dev/null
+++ b/cad/p5-GDS2/pkg-descr
@@ -0,0 +1,2 @@
+This is GDS2, a module for quickly creating programs to read,
+write, and manipulate GDS2 (GDSII) stream files.