aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-23 04:06:14 +0800
committermakc <makc@FreeBSD.org>2013-03-23 04:06:14 +0800
commit071186fd6d22f1abd16554cae92bf26af9d1cb4e (patch)
treeb368198f913179c06dafd19ac72527fcf9836f6d /cad
parenteda1ae8e7cf50659cf0b55fefdcae532e6ad0405 (diff)
downloadfreebsd-ports-gnome-071186fd6d22f1abd16554cae92bf26af9d1cb4e.tar.gz
freebsd-ports-gnome-071186fd6d22f1abd16554cae92bf26af9d1cb4e.tar.zst
freebsd-ports-gnome-071186fd6d22f1abd16554cae92bf26af9d1cb4e.zip
- convert USE_CMAKE to USES
- while here clean up some ports from CMAKE_VERBOSE, which is intended for users Approved by: portmgr (miwi)
Diffstat (limited to 'cad')
-rw-r--r--cad/brlcad/Makefile3
-rw-r--r--cad/gmsh/Makefile5
-rw-r--r--cad/kicad-devel/Makefile2
-rw-r--r--cad/kicad/Makefile2
-rw-r--r--cad/openvsp/Makefile2
-rw-r--r--cad/qfsm/Makefile2
6 files changed, 7 insertions, 9 deletions
diff --git a/cad/brlcad/Makefile b/cad/brlcad/Makefile
index 514213d65a3a..6321ae53b6eb 100644
--- a/cad/brlcad/Makefile
+++ b/cad/brlcad/Makefile
@@ -26,14 +26,13 @@ USE_GL= gl glu
USE_XORG= ice inputproto sm x11 xau xdamage xdmcp xext xfixes xft xi \
xproto xrender xscrnsaver xt xxf86vm
USE_GMAKE= yes
-USES= bison pathfix
+USES= bison pathfix cmake
USE_TCL= 85
USE_TK= 85
USE_LDCONFIG= yes
PREFIX?= ${LOCALBASE}/${PORTNAME}
NO_MTREE= yes
-USE_CMAKE= yes
MAKE_JOBS_SAFE= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index 81220fe1da13..709b7562e545 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -28,15 +28,14 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
SLAVEDIRS= cad/gmsh-occ
USE_FORTRAN= yes
-USE_CMAKE= yes
+USES= cmake
USE_GMAKE= yes
USE_GL= yes
ALL_TARGET= all
MAN1= gmsh.1
-CMAKE_ARGS+= -DCMAKE_SKIP_RPATH:BOOL=YES \
- -DCMAKE_VERBOSE_MAKEFILE:BOOL=YES
+CMAKE_ARGS+= -DCMAKE_SKIP_RPATH:BOOL=YES
.if !defined(WITHOUT_STATIC_LIB)
CMAKE_ARGS+= -DENABLE_BUILD_LIB=ON
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index 2057049dc031..d123ceef4cd6 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -38,7 +38,7 @@ PLIST_SUB= OPSYS=${OPSYS} \
BINS= cvpcb eeschema gerbview kicad pcbnew
EXTRAS2RM= linux-non_unicode linux wings3d LINUX.README \
contrib_makefiles.txt running_kicad_under_W98.txt
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}" \
-DKICAD_TESTING_VERSION=ON \
-DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index e1877b4760f1..6789efdee068 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -24,7 +24,7 @@ WRKSRC= ${WRKDIR}/kicad
USE_ZIP= yes
USE_DOS2UNIX= *.cmake
-USE_CMAKE= yes
+USES= cmake
USE_GL= yes
USE_WX= 2.8
WX_UNICODE= yes
diff --git a/cad/openvsp/Makefile b/cad/openvsp/Makefile
index 374ebfa6163f..d2f9a47b1920 100644
--- a/cad/openvsp/Makefile
+++ b/cad/openvsp/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
xcb:${PORTSDIR}/x11/libxcb
WRKSRC= ${WRKDIR}/OpenVSP-OpenVSP_${PORTVERSION}/src
-USE_CMAKE= yes
+USES= cmake
USE_DOS2UNIX= yes
USE_ICONV= yes
USE_XORG= ice sm x11 xau xdamage xdmcp xext xfixes xft \
diff --git a/cad/qfsm/Makefile b/cad/qfsm/Makefile
index 979c89825f0e..82bed0dbfced 100644
--- a/cad/qfsm/Makefile
+++ b/cad/qfsm/Makefile
@@ -24,7 +24,7 @@ USE_XORG= xi
USE_QT4= corelib gui qt3support svg xml \
moc_build qmake_build rcc_build uic_build
USE_GNOME= desktopfileutils
-USE_CMAKE= yes
+USES= cmake
INSTALLS_ICONS= yes
MAKE_JOBS_SAFE= yes